LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS (*)
User Name
Password
CentOS (*) This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices

Reply
 
Search this Thread
Old 07-31-2014, 04:10 PM   #1
steves504
LQ Newbie
 
Registered: Dec 2013
Posts: 4

Rep: Reputation: Disabled
Installing psycopg2 in centos6 with Python 2.6 and Python2.7 installed in the machine


When i use yum install python-psycopg2 , it installs it from python2.6 instead of python2.7. Using pip install psycopg2 does the same same thing and easy_install is the same result.

Trying to import it from the python2.7 shell, i get an error showing it is not available from that version.

I need some sort of direction/assistance please.
 
Old 08-01-2014, 02:39 AM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,953

Rep: Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720Reputation: 1720
this is the current centos 6.5 ?
6.5 is the ONLY one in the 6 series supported

too check
Code:
cat /etc/redhat-release
then also post the output of this
Code:
su -
yum repolist all
 
Old 08-04-2014, 11:18 AM   #3
steves504
LQ Newbie
 
Registered: Dec 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
I'm currently on CentOS release 6.5

$ yum repolist all

Loading mirror speeds from cached hostfile
* base: centos.expedientevirtual.com
* epel: mirror.sfo12.us.leaseweb.net
* extras: centos.corenetworks.net
* updates: mirrors.seas.harvard.edu
repo id repo name status
C6.0-base CentOS-6.0 - Base disabled
C6.0-centosplus CentOS-6.0 - CentOSPlus disabled
C6.0-contrib CentOS-6.0 - Contrib disabled
C6.0-extras CentOS-6.0 - Extras disabled
C6.0-updates CentOS-6.0 - Updates disabled
C6.1-base CentOS-6.1 - Base disabled
C6.1-centosplus CentOS-6.1 - CentOSPlus disabled
C6.1-contrib CentOS-6.1 - Contrib disabled
C6.1-extras CentOS-6.1 - Extras disabled
C6.1-updates CentOS-6.1 - Updates disabled
C6.2-base CentOS-6.2 - Base disabled
C6.2-centosplus CentOS-6.2 - CentOSPlus disabled
C6.2-contrib CentOS-6.2 - Contrib disabled
C6.2-extras CentOS-6.2 - Extras disabled
C6.2-updates CentOS-6.2 - Updates disabled
C6.3-base CentOS-6.3 - Base disabled
C6.3-centosplus CentOS-6.3 - CentOSPlus disabled
C6.3-contrib CentOS-6.3 - Contrib disabled
C6.3-extras CentOS-6.3 - Extras disabled
C6.3-updates CentOS-6.3 - Updates disabled
C6.4-base CentOS-6.4 - Base disabled
C6.4-centosplus CentOS-6.4 - CentOSPlus disabled
C6.4-contrib CentOS-6.4 - Contrib disabled
C6.4-extras CentOS-6.4 - Extras disabled
C6.4-updates CentOS-6.4 - Updates disabled
base CentOS-6 - Base enabled: 6,352+15
c6-media CentOS-6 - Media disabled
centosplus CentOS-6 - Plus disabled
contrib CentOS-6 - Contrib disabled
debug CentOS-6 - Debuginfo disabled
epel Extra Packages for Enterprise Linux 6 - enabled: 11,051
epel-debuginfo Extra Packages for Enterprise Linux 6 - disabled
epel-source Extra Packages for Enterprise Linux 6 - disabled
epel-testing Extra Packages for Enterprise Linux 6 - disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 6 - disabled
epel-testing-source Extra Packages for Enterprise Linux 6 - disabled
extras CentOS-6 - Extras enabled: 14
updates CentOS-6 - Updates enabled: 1,229+13
repolist: 18,646
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How can I make Python2.7 my default Python without deleting/removing python2.6. steves504 Linux - Server 2 03-21-2014 11:57 AM
problem in installing psycopg2 on fedora. abhijit_mohanta Linux - Software 1 08-06-2009 01:34 PM
Installing python-numpy in the python2.5 installation of eee-pc zoopside Linux - Software 3 04-01-2009 07:42 PM
[help]---Can't find Python library python2.5 LinczO_Dz Linux - Software 6 04-19-2008 10:09 AM
Python2.5-devel is unable to find installed Python2.5 Setya Suse/Novell 1 06-08-2007 01:35 AM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration