LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   cAos (http://www.linuxquestions.org/questions/caos-44/)
-   -   Grub, can someone posts their Menu.lst please (http://www.linuxquestions.org/questions/caos-44/grub-can-someone-posts-their-menu-lst-please-245158/)

webwolf70 10-20-2004 12:15 PM

Grub, can someone posts their Menu.lst please
 
Could someone post their menu.lst. I am trying to edit my menu.lst in Mandrake and I can't get cAos to boot. I keep getting a kernel panic. I would like to compare a menu.lst from someone who has a working, booting cAos. It booted fine until I started playing around with grub.

Also. I just installed cAos. I have had it for a couple of months but I was stuck with Dial-Up. Now that I have broadband I had to give it a try.


Webwolf

apolinsky 10-20-2004 12:27 PM

There is excellent documentation of grub at the gnu site (www.gnu.org)

gregk433 10-20-2004 01:05 PM

There shouldnt be anything special about the caos grub kernel lines:

Code:

title cAos: Community Linux 2.0 (2.6.8.1-20.caos)
        kernel /vmlinuz-2.6.8.1-20.caos root=/dev/hda2
        initrd /initrd-2.6.8.1-20.caos.img

What is the panic that you are seeing? Is the initrd loading?

webwolf70 10-20-2004 01:48 PM

The message I am getting is this.

Mount error 2 mounting sysfs
loading jbd.ko module
loading ext3.ko module
creating block devices
creating root devices
unmount /sys failed: 2
mounting root filesystem
mount error 6 mounting ext3
switching to newroot
switchroot: mount failed: 22
kernel panic: attemted to kill init!



Webwolf

gregk433 10-20-2004 02:01 PM

That is kinda weird. I assume this is a caos2 system because of the /sys mount.

If so, when was it installed?

Did it ever work/when did it stop?

When was it last updated (via yum) before it died?

webwolf70 10-20-2004 03:48 PM

Quote:

Originally posted by gregk433
That is kinda weird. I assume this is a caos2 system because of the /sys mount.

If so, when was it installed?

Did it ever work/when did it stop?

When was it last updated (via yum) before it died?


I just installed it. It seemed to download and install everything without any problems. It booted fine but when it did boot the screen was distorted. It started in text mode but it was hard to make out. So I figured I would get it set up with Grub through Mandrake 10.1 Community, get some info, etc, and work on it later. But it won't boot now.

So do you think it might not have anything to do with Grub?

Edit: And yes it is Community Linux 2.0 (2.6.8.1-18.caos)


Webwolf

gregk433 10-21-2004 12:37 AM

There is a syslinux boot option that disables the grub boot splash image. I have seen that cause problems before. Try to comment out the splashscreen image...

Did you do a yum update recently (in the last week)? If so, we will need to recreate your initial ram disk for udev support.

Can you post your grub.conf? I am interested in the header and the cAos stanza.


All times are GMT -5. The time now is 06:21 PM.