LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices



Reply
 
Search this Thread
Old 06-22-2011, 02:44 PM   #1
bill54
LQ Newbie
 
Registered: Jun 2011
Location: colorado
Distribution: bodhi, ubuntu, debian
Posts: 4

Rep: Reputation: Disabled
Xserver startup configuration


The default Bodhi Xserver starts with -nolisten tcp - and while I get that this is more secure, I need to let the Xserver listen for TCP connections for a couple of work-related apps that simply are old-school X, and won't be changed. Ssh port-forwarding does not work here. These apps take the value of $DISPLAY and open X clients on the local server - but based on passing this variable on to another host. Thus, it requires $DISPLAY to be in the form nnn.nnn.nnn.nnn:nn

So, I have looked, but cannot get the Xserver to start without "-nolisten tcp". How does this get configured?
 
Old 06-23-2011, 07:20 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
Quote:
man xserver
man x
Quote: "The X server is usually started from the X Display Manager program xdm(1) or a similar display manager program"...

HTH.
 
Old 06-23-2011, 10:02 AM   #3
bill54
LQ Newbie
 
Registered: Jun 2011
Location: colorado
Distribution: bodhi, ubuntu, debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by JZL240I-U View Post
Quote: "The X server is usually started from the X Display Manager program xdm(1) or a similar display manager program"...

HTH.

Well, thank you for the admonishment. It is *so* much help when someone tells you to read the man pages.

But I was looking for some bodhi linux expert, not a crackpot.

I have modified the file /etc/X11/xinit/xserverrc - the line in that file is
exec /usr/bin/X -nolisten tcp "$@"

I took out the "-nolisten tcp", and restarted X, rebooted. No change. So, is the Xserver compiled with this hardcoded?
 
Old 06-23-2011, 10:05 AM   #4
bill54
LQ Newbie
 
Registered: Jun 2011
Location: colorado
Distribution: bodhi, ubuntu, debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bill54 View Post
Well, thank you for the admonishment. It is *so* much help when someone tells you to read the man pages.

But I was looking for some bodhi linux expert, not a crackpot.

I have modified the file /etc/X11/xinit/xserverrc - the line in that file is
exec /usr/bin/X -nolisten tcp "$@"

I took out the "-nolisten tcp", and restarted X, rebooted. No change. So, is the Xserver compiled with this hardcoded?


I must add that in ubuntu, you can change a variable in /etc/gdm/gdm.conf which changes the behavior. Same with other window managers. In bodhi, I am perplexed because there is lxdm and enlightenment and I have been unable to discover which one changes the X server behavior.
 
Old 06-23-2011, 10:09 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
Quote:
Originally Posted by bill54 View Post
...
I have modified the file /etc/X11/xinit/xserverrc - the line in that file is exec /usr/bin/X -nolisten tcp "$@"

I took out the "-nolisten tcp", and restarted X, rebooted. No change. So, is the Xserver compiled with this hardcoded?
No need to get touchy. You didn't write that you did that already.

I can't prove it but I doubt that the Xserver was compiled with this hardcoded. From my limited experience with x I'd guess that it is a side effect from some other option (which I can't pinpoint in the man page). I guess you'll have to wait anyhow for the expert you hoped for .
 
Old 06-23-2011, 10:13 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
Quote:
Originally Posted by bill54 View Post
... change a variable in /etc/gdm/gdm.conf which changes the behavior. In bodhi, I am perplexed because there is lxdm and enlightenment and I have been unable to discover which one changes the X server behavior.
Sorry to touch on the man pages again . I found
Quote:
-auth authorization-file specifies a file which contains a collection of authorization records used to authenticate access. See also the xdm(1) and xsecurity(7) manual pages.
That of any help?
 
Old 06-23-2011, 05:54 PM   #7
bill54
LQ Newbie
 
Registered: Jun 2011
Location: colorado
Distribution: bodhi, ubuntu, debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by JZL240I-U View Post
Sorry to touch on the man pages again . I found

That of any help?
I have isolated the problem a bit more. I installed xdm and made it the default login manager. When I logged in, the X process was not running with "-nolisten tcp" - so I know that the Xserver on my machine can be started the way I need it to be.
So, the issue is with lxdm. I really like the way the bodhi linux developers integrated everything with E17 and I don't want to give that up. There has to be a way to configure lxdm with Xserver arguments. I just do not know what file to edit, and in what form the variable gets set.
 
Old 06-23-2011, 08:00 PM   #8
Jeff91
Bodhi Developer
 
Registered: Jan 2009
Location: Alsip, IL
Distribution: Bodhi and Maemo
Posts: 300

Rep: Reputation: 33
We choose LXDM because it is light and fairly basic.

For what you are looking to do is there a reason you can't just install/use GDM as it seems to support what you need?

~Jeff
 
Old 06-24-2011, 02:45 AM   #9
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,687

Rep: Reputation: Disabled
From the sound of it I'd guessed that LXDM is closest to XDM. Am I wrong or why do you suggest DDM?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver lost configuration, dpkg-reconfigure xserver-xorg isn't helping bezdomny Linux - Software 5 07-13-2008 01:33 PM
openSUSE failes to show xserver on startup Zoiked Suse/Novell 1 10-25-2007 06:08 PM
Problems on startup with xserver failed amuno Linux - Software 4 07-18-2007 04:38 PM
Strange XServer behaviour on startup elven Linux - Newbie 2 01-25-2005 10:44 AM
xserver crashes at startup -=bcc=-E-nigma Linux - Hardware 1 04-27-2003 08:54 AM


All times are GMT -5. The time now is 08:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration