LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (http://www.linuxquestions.org/questions/bodhi-92/)
-   -   Xserver startup configuration (http://www.linuxquestions.org/questions/bodhi-92/xserver-startup-configuration-887781/)

bill54 06-22-2011 01:44 PM

Xserver startup configuration
 
The default Bodhi Xserver starts with -nolisten tcp - and while I get that this is more secure, I need to let the Xserver listen for TCP connections for a couple of work-related apps that simply are old-school X, and won't be changed. Ssh port-forwarding does not work here. These apps take the value of $DISPLAY and open X clients on the local server - but based on passing this variable on to another host. Thus, it requires $DISPLAY to be in the form nnn.nnn.nnn.nnn:nn

So, I have looked, but cannot get the Xserver to start without "-nolisten tcp". How does this get configured?

JZL240I-U 06-23-2011 06:20 AM

Quote:

man xserver
man x
Quote: "The X server is usually started from the X Display Manager program xdm(1) or a similar display manager program"...

HTH.

bill54 06-23-2011 09:02 AM

Quote:

Originally Posted by JZL240I-U (Post 4393627)
Quote: "The X server is usually started from the X Display Manager program xdm(1) or a similar display manager program"...

HTH.


Well, thank you for the admonishment. It is *so* much help when someone tells you to read the man pages.

But I was looking for some bodhi linux expert, not a crackpot.

I have modified the file /etc/X11/xinit/xserverrc - the line in that file is
exec /usr/bin/X -nolisten tcp "$@"

I took out the "-nolisten tcp", and restarted X, rebooted. No change. So, is the Xserver compiled with this hardcoded?

bill54 06-23-2011 09:05 AM

Quote:

Originally Posted by bill54 (Post 4393728)
Well, thank you for the admonishment. It is *so* much help when someone tells you to read the man pages.

But I was looking for some bodhi linux expert, not a crackpot.

I have modified the file /etc/X11/xinit/xserverrc - the line in that file is
exec /usr/bin/X -nolisten tcp "$@"

I took out the "-nolisten tcp", and restarted X, rebooted. No change. So, is the Xserver compiled with this hardcoded?



I must add that in ubuntu, you can change a variable in /etc/gdm/gdm.conf which changes the behavior. Same with other window managers. In bodhi, I am perplexed because there is lxdm and enlightenment and I have been unable to discover which one changes the X server behavior.

JZL240I-U 06-23-2011 09:09 AM

Quote:

Originally Posted by bill54 (Post 4393728)
...
I have modified the file /etc/X11/xinit/xserverrc - the line in that file is exec /usr/bin/X -nolisten tcp "$@"

I took out the "-nolisten tcp", and restarted X, rebooted. No change. So, is the Xserver compiled with this hardcoded?

No need to get touchy. You didn't write that you did that already.

I can't prove it but I doubt that the Xserver was compiled with this hardcoded. From my limited experience with x I'd guess that it is a side effect from some other option (which I can't pinpoint in the man page). I guess you'll have to wait anyhow for the expert you hoped for ;).

JZL240I-U 06-23-2011 09:13 AM

Quote:

Originally Posted by bill54 (Post 4393730)
... change a variable in /etc/gdm/gdm.conf which changes the behavior. In bodhi, I am perplexed because there is lxdm and enlightenment and I have been unable to discover which one changes the X server behavior.

Sorry to touch on the man pages again ;). I found
Quote:

-auth authorization-file specifies a file which contains a collection of authorization records used to authenticate access. See also the xdm(1) and xsecurity(7) manual pages.
That of any help?

bill54 06-23-2011 04:54 PM

Quote:

Originally Posted by JZL240I-U (Post 4393738)
Sorry to touch on the man pages again ;). I found

That of any help?

I have isolated the problem a bit more. I installed xdm and made it the default login manager. When I logged in, the X process was not running with "-nolisten tcp" - so I know that the Xserver on my machine can be started the way I need it to be.
So, the issue is with lxdm. I really like the way the bodhi linux developers integrated everything with E17 and I don't want to give that up. There has to be a way to configure lxdm with Xserver arguments. I just do not know what file to edit, and in what form the variable gets set.

Jeff91 06-23-2011 07:00 PM

We choose LXDM because it is light and fairly basic.

For what you are looking to do is there a reason you can't just install/use GDM as it seems to support what you need?

~Jeff

JZL240I-U 06-24-2011 01:45 AM

From the sound of it I'd guessed that LXDM is closest to XDM. Am I wrong or why do you suggest DDM?


All times are GMT -5. The time now is 11:12 AM.