LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Blogs > Zoutmax
User Name
Password

Notices

Rate this Entry

No sound Hauppauge WinTV-HVR1110 DVB-T/Hybrid Ubuntu 9.0.4 (Cause and Workarround)

Posted 04-28-2009 at 05:07 PM by Zoutmax
Updated 04-29-2009 at 02:59 PM by Zoutmax

Hi,

I try to make the sound working on my :

Code:
Hauppauge WinTV-HVR1110 DVB-T/Hybrid
From lspci output :

Code:
Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
I am running Ubuntu 9.0.4 jaunty:

Code:
Ubuntu 9.0.4 Linux 2.6.28-11-generic
I tried with the build in drivers from the Ubuntu 9.0.4 install disk,
and with the drivers that i compiled from Linux TV org (V4L-DVB).

Both give me the same result : No TV or radio tuner sound output

The sound is working fine on this system only this TV card does not produce any...

I checked the volume parameters tried with different sound servers (alsa, oss, etc..) no results.

I assume that the sound card i am using is OK, details from lspci :

Code:
Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 02)
Working on the TV card tested with TV Time and K Radio :

Video (the video output is ok, i can watch TV on the different channels)
Video Channel Seeking (the card detect all my TV channels but no sound)
Radio Channel Seeking (the card detect all my Radio channels but no sound)
Remote Control Lirc (Infrared remote control plugged in the TV card working fine)

The only problem is that i can't get any sound output from this TV card, i checked the modules :

Code:
lsmod
Module                  Size  Used by
binfmt_misc            16776  1
radeon                342816  2
drm                    96296  3 radeon
bridge                 56340  0
stp                    10500  1 bridge
bnep                   20224  2
ivtv                  150436  0
i2c_algo_bit           14084  1 ivtv
cx2341x                22020  1 ivtv
lirc_dev               19892  0
input_polldev          11912  0
video                  25360  0
output                 11008  1 video
lp                     17156  0
tda1004x               24068  1
saa7134_dvb            30476  0
videobuf_dvb           15108  1 saa7134_dvb
dvb_core               93312  1 videobuf_dvb
saa7134_alsa           20000  0
ir_kbd_i2c             16272  0
tda827x                18052  2
ppdev                  15620  0
snd_intel8x0           37532  3
snd_ac97_codec        112292  1 snd_intel8x0
ac97_bus                9856  1 snd_ac97_codec
snd_pcm_oss            46336  0
snd_mixer_oss          22656  1 snd_pcm_oss
snd_pcm                82948  4 saa7134_alsa,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
tda8290                21000  1
snd_seq_dummy          10756  0
snd_seq_oss            37760  0
tuner                  30984  1
snd_seq_midi           14336  0
snd_rawmidi            29696  1 snd_seq_midi
snd_seq_midi_event     15104  2 snd_seq_oss,snd_seq_midi
snd_seq                56880  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29704  2 snd_pcm,snd_seq
snd_seq_device         14988  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
saa7134               160716  2 saa7134_dvb,saa7134_alsa
ir_common              56068  2 ir_kbd_i2c,saa7134
v4l2_common            23808  4 ivtv,cx2341x,tuner,saa7134
snd                    62628  17 saa7134_alsa,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
videodev               44832  4 ivtv,tuner,saa7134,v4l2_common
v4l1_compat            21764  1 videodev
iTCO_wdt               19108  0
iTCO_vendor_support    11652  1 iTCO_wdt
psmouse                61972  0
videobuf_dma_sg        20484  3 saa7134_dvb,saa7134_alsa,saa7134
pcspkr                 10496  0
soundcore              15200  1 snd
snd_page_alloc         16904  2 snd_intel8x0,snd_pcm
serio_raw              13316  0
intel_agp              34108  1
videobuf_core          26244  3 videobuf_dvb,saa7134,videobuf_dma_sg
tveeprom               20228  2 ivtv,saa7134
agpgart                42696  2 drm,intel_agp
shpchp                 40212  0
parport_pc             40100  1
parport                42220  3 lp,ppdev,parport_pc
usbhid                 42336  0
3c59x                  49192  0
mii                    13312  1 3c59x
floppy                 64324  0
fbcon                  46112  0
tileblit               10752  1 fbcon
font                   16384  1 fbcon
bitblit                13824  1 fbcon
softcursor              9984  1 bitblit


They look loaded,then i tried to reroute the sound to alsa by using sox:

Code:
sox -q -c 2 -s -r 32000 -t alsa hw:1 -t alsa -r 32000 hw:0
This is the only way i can get the sound but it implicate starting sox every time i want to use TV or Radio...........

The /var/messages does not show any problems :

Code:
Apr 29 00:53:27 Ubuntu kernel: [   13.200361] Linux video capture interface: v2.00
Apr 29 00:53:27 Ubuntu kernel: [   13.446769] saa7130/34: v4l2 driver version 0.2.15 loaded
Apr 29 00:53:27 Ubuntu kernel: [   13.447106] saa7134 0000:02:09.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Apr 29 00:53:27 Ubuntu kernel: [   13.447119] saa7133[0]: found at 0000:02:09.0, rev: 209, irq: 17, latency: 66, mmio: 0x40000000
Apr 29 00:53:27 Ubuntu kernel: [   13.447133] saa7133[0]: subsystem: 0070:6701, board: Hauppauge WinTV-HVR1110 DVB-T/Hybrid [card=104,autodetected]
Apr 29 00:53:27 Ubuntu kernel: [   13.447248] saa7133[0]: board init: gpio is 6400000
Apr 29 00:53:27 Ubuntu kernel: [   13.606123] tveeprom 0-0050: Hauppauge model 67019, rev B4B4, serial# 5239264
Apr 29 00:53:27 Ubuntu kernel: [   13.606131] tveeprom 0-0050: MAC address is 00-0D-FE-4F-F1-E0
Apr 29 00:53:27 Ubuntu kernel: [   13.606137] tveeprom 0-0050: tuner model is Philips 8275A (idx 114, type 4)
Apr 29 00:53:27 Ubuntu kernel: [   13.606145] tveeprom 0-0050: TV standards PAL(B/G) NTSC(M) PAL(I) SECAM(L/L') PAL(D/D1/K) ATSC/DVB Digital (eeprom 0xfc)
Apr 29 00:53:27 Ubuntu kernel: [   13.606152] tveeprom 0-0050: audio processor is SAA7131 (idx 41)
Apr 29 00:53:27 Ubuntu kernel: [   13.606159] tveeprom 0-0050: decoder processor is SAA7131 (idx 35)
Apr 29 00:53:27 Ubuntu kernel: [   13.606164] tveeprom 0-0050: has radio, has IR receiver, has IR transmitter
Apr 29 00:53:27 Ubuntu kernel: [   13.606170] saa7133[0]: hauppauge eeprom: model=67019
Apr 29 00:53:27 Ubuntu kernel: [   13.885196] tuner 0-004b: chip found @ 0x96 (saa7133[0])
Apr 29 00:53:27 Ubuntu kernel: [   13.964088] tda829x 0-004b: setting tuner address to 61
Apr 29 00:53:27 Ubuntu kernel: [   14.022981] Intel ICH 0000:00:1f.5: PCI INT B -> GSI 17 (level, low) -> IRQ 17
Apr 29 00:53:27 Ubuntu kernel: [   14.045005] ppdev: user-space parallel port driver
Apr 29 00:53:27 Ubuntu kernel: [   14.096084] tda829x 0-004b: type set to tda8290+75a
Apr 29 00:53:27 Ubuntu kernel: [   14.644024] intel8x0_measure_ac97_clock: measured 55969 usecs
Apr 29 00:53:27 Ubuntu kernel: [   14.644033] intel8x0: clocking to 41146
Apr 29 00:53:27 Ubuntu kernel: [   17.988392] input: HVR 1110 as /devices/virtual/input/input6
Apr 29 00:53:27 Ubuntu kernel: [   17.994320] ir-kbd-i2c: HVR 1110 detected at i2c-0/0-0071/ir0 [saa7133[0]]
Apr 29 00:53:27 Ubuntu kernel: [   18.056323] saa7133[0]: registered device video0 [v4l2]
Apr 29 00:53:27 Ubuntu kernel: [   18.056442] saa7133[0]: registered device vbi0
Apr 29 00:53:27 Ubuntu kernel: [   18.056560] saa7133[0]: registered device radio0
Apr 29 00:53:27 Ubuntu kernel: [   18.086624] saa7134 ALSA driver for DMA sound loaded
Apr 29 00:53:27 Ubuntu kernel: [   18.086695] saa7133[0]/alsa: saa7133[0] at 0x40000000 irq 17 registered as card -2
Apr 29 00:53:27 Ubuntu kernel: [   18.214944] dvb_init() allocating 1 frontend
Apr 29 00:53:27 Ubuntu kernel: [   18.256592] DVB: registering new adapter (saa7133[0])
Apr 29 00:53:27 Ubuntu kernel: [   18.256610] DVB: registering adapter 0 frontend -858993460 (Philips TDA10046H DVB-T)...
Apr 29 00:53:27 Ubuntu kernel: [   18.331451] tda1004x: setting up plls for 48MHz sampling clock
Apr 29 00:53:27 Ubuntu kernel: [   18.497660] lp0: using parport0 (interrupt-driven).
Apr 29 00:53:27 Ubuntu kernel: [   18.621371] tda1004x: found firmware revision 20 -- ok
Apr 29 00:53:28 Ubuntu kernel: [   24.071387] lirc_dev: IR Remote Control driver registered, major 61 
Apr 29 00:53:28 Ubuntu kernel: [   24.183952] ivtv: Start initialization, version 1.4.1
Apr 29 00:53:28 Ubuntu kernel: [   24.186600] ivtv: End initialization

Everything look fine to me but no TV / Radio sound output without using sox.

The Card is not broken because this system has dual boot and when i run windows everything is fine :O)

I believe that the drivers are not able to route the sound from the pci port to the Alsa server.

This TV card does not have any jack sound output, no wire possible between TV card and sound card, sound goes over PCI no choice,which make a latency when using sox with Linux or under Windows i still have the sound not properly synchronized (really minimal but noticeable if you pay attention).

The Wire (Double jack 3.5) connection between TV sound out and the sound card Line In was a better concept as this work fine on my other Pinnacle TV Tuner with no latency but just fine...

Please doe anyone has any idea for get the TV sound from my HVR1110 over pci without using any service like sox ? (not working, big latency)

or maybe working HVR1110 drivers on Ubuntu 9.0.4, or a "wire Patch" who send the TV pci sound output to the sound server will help me...

Thx
Posted in Uncategorized
Views 2709 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 08:49 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration