LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Blogs > vik
User Name
Password

Notices

Rate this Entry

Neverwinter Online with wine 64-bit 1.6-rc4

Posted 07-04-2013 at 02:51 AM by vik
Updated 07-07-2013 at 12:44 AM by vik

Background: this is for a 64-bit linux system with alsa installed and no pulseaudio. Derived from: http://appdb.winehq.org/objectManage...estingId=78390 and http://appdb.winehq.org/objectManage...estingId=78500 with a few tweaks for my setup.
  • Download Neverwinter Online.
  • We can't use 64-bit with a 32-bit compatibility layer (WoW) in this case as winetricks won't install ie8 correctly, so we force a 32-bit wine.
    Code:
    export WINEARCH=win32
  • (Optional) Set the WINEPREFIX variable. For some strange reason, if you point the wineprefix to a folder that already exists you'll get an error about "WINEARCH set to win32 but is a 64-bit installation."
    Code:
    export WINEPREFIX=/game_location/folder_that_doesnt_exist
  • Now configure a few options in wine to make the game run better.
    Code:
    winecfg
    -Applications->Windows Version: Windows XP
    -Graphics->Automatically capture the mouse in full-screen windows
    -Graphics->*Don't* allow the window manager to decorate the windows
    -Graphics->*Don't* allow the window manager to control the windows
    -Graphics->Emulate a virtual desktop (resolution same size as your monitor). This will significantly increase your FPS.
  • Install IE 8. This solves the problem if you try to use wine's built-in version of IE, where you press the "Login" button from the launcher and nothing happens.
    Code:
    winetricks ie8
  • Now install Neverwinter.
    Code:
    wine "/game_location/Neverwinter NW.1.20130416a.6/setup.exe"
  • Now double-click the wine shortcut file to start Neverwinter. Click on Options->Advanced Options and type -enablerawinputsupport 0. The camera will be very jerky when moving the mouse: this fixes it.
  • When you successfully login the first time, after the initial loading bar you'll see another window that takes forever. This is normal, just wait it out or try restarting. As noted in the comments, you can fix this by finding your video card PCI device and vendor ID and adding it to the wine registry with regedit. This may help: http://wiki.winehq.org/UsefulRegistryKeys
  • Inside game options, turn on vertical sync and set mode to full screen. I didn't need to modify the other settings much.
Posted in Uncategorized
Views 2468 Comments 1
« Prev     Main     Next »
Total Comments 1

Comments

  1. Old Comment
    On my system, compiling WINE for 32-bit only, I get a bit more fps stability (and less kb and mouse lag) if I set to emulate a virtual desktop at the same size as my full screen resolution.

    Thanks for the raw input support tip.

    To speed up the 2nd loading screen (and not running the risk of your login timing out), use regedit to add the PCI device and vendor ID to your WINE registry. Seems NW wants to autodetect the GPU and has a hard time.

    Good thing you have an i7. My Athlon64 X2 runs out of head room - way too much overhead compared to Win7. I suspect a lot of CPU software rendering.
    Posted 07-05-2013 at 06:24 PM by kingbeowulf kingbeowulf is offline
 

  



All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration