LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Blogs > trevorparsons
User Name
Password

Notices

Rate this Entry

Kate and Phil

Posted 02-09-2012 at 04:51 PM by trevorparsons
Updated 02-09-2012 at 05:32 PM by trevorparsons (Clarity)

I use KDE's Kate editor a lot. Recently, it has complained about opening some of my messy HTML files, giving the following slightly opaque error message:

Quote:
The file [whatever] was opened and contained too long lines (more than 1,024 characters). Too long lines were wrapped and the document is set to read-only mode, as saving will modify its content.
I searched for a portion of this text using Startpage and found just one result, in a post to the kde-commits list, pertaining to bug 234475.

Well, I've not yet experienced such hangs when opening files, so I threw caution to the wind and, in Configure Kate > Open/Save, I increased the Line Limit Length from 1024 to 2048.

Now my file opens and is writeable.

For some reason this brought to mind the time a few years ago when the estimable Phil Hands decided he was selling himself short and doubled his day rate from 512 to 1024. Let me see what he's charging nowadays...

Well, Phil's a reasonable guy. In these straitened times, he has held his price, more or less. He now charges in guineas (maybe he always did and I forgot). So that's 1024 times 21 shillings (or 1.05 in the new money), making 1075 and four shillings (1075.20). Plus VAT.

As far as I know, no 'hang opening file' bug has yet been filed on Phil, which is good, because we want the co-sponsor and maintainer of the UK Debian mirror to be reasonably stable.
Posted in Uncategorized
Views 4474 Comments 3
« Prev     Main     Next »
Total Comments 3

Comments

  1. Old Comment
    Hi,

    I just stumbled over the exact same reason. Kate 3.7.97, KDE 4.8, Kubuntu 11.10

    I wanted to edit a .tex file. But after increasing the limit in Settings -> Save/Load to 2048 and later to even 100'000 it still wouldn't let me edit the file. The longest line I could spot in the file is just below 2000 characters. I only got the error message once, now it just opens R/O without any comment.

    I feel very strange about this limitation. It would be far more sensible to issue a warning but open for editing anyway, and then on save ask again if lines should be broken (optionally!).

    Any hint how to open my file for editing with Kate?
    Posted 03-06-2012 at 05:22 AM by mogliii mogliii is offline
  2. Old Comment
    No idea how to get around the .tex file problem, sorry mogliii.

    Your suggestions for warning dialogs sound sensible.
    Posted 03-24-2012 at 08:13 PM by trevorparsons trevorparsons is offline
  3. Old Comment
    I also found that the file was still Read Only even after extending the limit.

    If I renamed the file and opened it with the new limit then I could edit it. It seems that once Kate has marked a particular file "read only" it keeps it that way.

    To edit the file under its original name, edit the file (but not using Kate!) ~/.kde/share/apps/kate/metainfos. Search the file for the affected file name's metadata and change "ReadWrite=false" to "ReadWrite=true".

    If you have saved the file in a session then also make the cahnge to the file under the sessions directory.
    Posted 05-15-2012 at 05:09 AM by simonb simonb is offline
    Updated 05-15-2012 at 05:20 AM by simonb
 

  



All times are GMT -5. The time now is 07:32 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration