LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Blogs > taupist
User Name
Password

Notices

Rate this Entry

Centrino / IPW 2200 Wireless for Mandriva 2007

Posted 02-23-2007 at 10:52 AM by taupist

It's absolutely critical that you get the right firmware for your driver . . .

http://ipw2200.sourceforge.net/firmware.php

For Mandriva 2007 that would be the 3.0 version of the firmware.

You then have to create a soft link to "/lib/firmware" (which is where your firmware should be); As Root, issue this command in the terminal ln -s /lib/firmware /etc/firmware Next, open "Configure Your Computer", go to "Set up a new network interface" and you should see a list with "eth2: Intel Corp.|Intel(R) Pro Wireless . . ."
Select this item from the list and click next, you should be able to accept default values.
Next, go to "Reconfigure a network interface", you should see a page called "Manage connections" with a dropdown box at the top. For each item in the dropdown box (including the wireless), go to the "Options" tab and make sure that the "start at boot" option is unchecked. Mandriva 2007 has a habit of freezing during the boot process if the "Start at boot" option is enabled.
When you get to the wireless item in the dropdown box, do the same and also go to the "Wireless" tab and make sure the field "ESSID" is blank. This is NOT true of all Linux distros, some are scripted to default to "any" if this field is left blank, Live CD distros are often this way.
When you are finished with all the items in the dropdown box click "Ok".
Next go to the "Security" section and "Set up a personal firewall . . .", make sure none of the boxes on the first screen are checked and follow through to the third screen where there is a dropdown box at the bottom of the screen. In this dropdown box, select the wireless interface (possibly, "eth2") and follow through with the rest of the options.
Starting with Mandriva 2007, the firewall no longer has a "deny all" policy. Any interface that isn't automatically set up when the system is installed is left wide open and you are vulnerable to attack. By all means, make sure that the firewall is watching the interface(s). You should be able to reboot and select a network from the net applet in the system tray, you'll have to type in you're Root password to connect.
For an explanation of why it shouldn't be automatic read the previous entry in my blog "Wireless Security and MITM".
Best of luck to you and enjoy!
Posted in Uncategorized
Views 796 Comments 0
« Prev     Main     Next »

  



All times are GMT -5. The time now is 08:16 PM.

Main Menu

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration