LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Blogs > MrCode
User Name
Password

Notices

This is the first "blog" of any kind I've ever had, so it's probably not the greatest...

Just a little snippet about me:

I'd like to consider myself relatively tech-savvy; obviously I use Linux (Arch to be precise; K.I.S.S. FTW), and I enjoy learning new things about computers in general (both software and hardware-related).

This blog is mostly just for whenever I feel like telling the world about my experiences with computers/Linux (or just life in general), or just posting for the hell of it.
Rate this Entry

Power usage: it just keeps going up and up and up...

Posted 02-20-2011 at 10:39 AM by MrCode
Updated 02-20-2011 at 10:42 AM by MrCode
Tags linux

...with each new kernel, it seems.

A while back, when I was still running with kernel 2.6.34/35 (and earlier) on my lappy, PowerTOP would show idle power usage anywhere from 10.x W to the occasional dip into the single-digits. Now on kernel 2.6.37, it never goes below 11 W, and sometimes hovers around 12...this annoys me, because it does take a hit on my lappy's battery life (what once was 4+ hours is now 3- ).

The backlight is always at the lowest level when I'm on battery (thanks to the fact that I have to add acpi_backlight=vendor to my GRUB kernel line, rendering it binary [lowest or highest brightness] because setting the backlight manually no longer works ), and I have the HDD set to spin down after a set period of inactivity, along with a few other power management options set in laptop-mode-tools.

Anyhow, I'm just wondering if my lappy's power consumption will continue to creep up and up with each new kernel revision, or if I'll be able to still use it like *ahem* a laptop.

Another thing is that on occasion a very large number of CPU wakeups is caused by something PowerTOP dubs "[extra timer interrupt]". This of course causes more of a power drain, too. Now, I've Googled this, and it appears to have to do with the hardware timer for events and such, but I haven't the slightest idea where to start to fix that (I've already checked for an "HPET" option in my BIOS, but none exists).
Views 2424 Comments 3
« Prev     Main     Next »
Total Comments 3

Comments

  1. Old Comment
    Are you compiling these kernels or is it a system update between OSes?

    If you are compiling and the lower usage was from your OS repositories, did you use the same config file and only update the options that changed?

    There are a few timer type values in the kernel config. If you are using the menu, I think it's under general setup. There is one for process priority which could control the snappyness of desktop activities vs. deamons, one for timer frequncy, and if not included in the frequency there is one for setting an on demand timer so that it only goes off when there is activity. Also I'm not sure if the high resolution timer option is part of the timer frequency.
    Posted 02-21-2011 at 01:32 PM by lumak lumak is offline
  2. Old Comment
    Quote:
    Are you compiling these kernels or is it a system update between OSes?
    These are "stock" kernels from the Arch repos. The only time I've tried "compiling it myself" was when I was experimenting with "kernel26-bfs" and "kernel26-ck" on my desktop machine (of course 90% of the work was done for me by makepkg ). I also tried compiling a new kernel for gNewSense in a virtual machine some time back (the packaged one for it was so old that the VB Guest Additions' 3D driver wouldn't work), using the menu interface for configuration, but when I tried to boot it, it would just stop cold. Nothing. Obviously I did something very wrong.
    Posted 02-21-2011 at 01:50 PM by MrCode MrCode is offline
    Updated 02-21-2011 at 01:52 PM by MrCode
  3. Old Comment
    UPDATE: After doing a sort of "re-build" (had to take the lappy apart to remove a piece of broken-off plastic that was rattling around in the fan area), powertop shows usage back down in the 9-10 W range.

    However, the "[extra timer interrupt]" issue still hasn't gone away.

    My guess as to why the power usage was up: the fan was going faster than normal to keep everything adequately cool since the vents were kinda blocked up. It's not Linux's fault at all.
    Posted 03-22-2011 at 06:15 PM by MrCode MrCode is offline
    Updated 03-22-2011 at 06:17 PM by MrCode
 

  



All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration