LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Blogs > kostya
User Name
Password

Notices



Rate this Entry

Screensaver lock screen, and other pesky problems (now solved!!!!)

Posted 04-03-2010 at 07:19 PM by kostya

OK, folks.
As most things I could share are already present here in one thread or another, let me just tell MY story of how I found solutions to the problems I encountered.

And the first one in line to be told is the well-known "how to disable inactivity screen lock in KDE4???" problem. The screensaver starts after "..." minutes, you want to go back to your screen ... and must type in your password! You know the story.

... Ha-ha-ha! So simple. It is right there, in your System settings --> Desktop --> Screensaver, as everyone knows but too well, is it not???

Neither should one think, that I only started using Linux two months ago -- I've been using it ever since the kernel 2.4.18, which brings me back to 2002 according to the www.kernel.org chronology.

And NO, in MY installation of Fedora 12 there was NO "Screensaver" section in System settings > Desktop.
How come there was no Screensaver section in there?? Don't know, ask me another! All the package dependencies were there, but the Screensaver System Settings section -- it was not, believe it or not.

Intuition told me, googling would be to no avail, and so it proved to be. Finally I felt, that I'd sooner find the solution in the very source code of xscreensaver itself, which would also be educative... but wait a minute! Why not try first this (last) one:

$ man xscreensaver

Yes, you can ROFLOL, but I had forgotten about that old and faithful friend of Linux users -- the RT(F)M thing. Now there is nothing strange in my total ignorance of the xscreensaver particulars, as the one and only time I was compelled to edit manually its "raw" configuration was when I was configuring my Solaris 9 ™ installation (which I did just for the very sport of it).
OK, in Solaris ™ you can expect being compelled to edit configuration files in terminal window, for that system was designed with this very thing in mind, that "uninitiated" might by no means be able to use it. But Linux? And Fedora 12?? I felt myself betrayed.
...Meantime, the reading of the xscreensaver's (F)M told me after a while, that somewhere there in your ~/.xscreensaver configuration file there must be one very interesting line:
lock: True
-- which is doing the whole thing. And YES! It really WAS right there, and putting the (boolean)"False" value to the "lock:" option turned down the pesky screen lock.
...........................................................
The rest of the story is rather short.
As it happens but too often in this life, some time passed, some updates, I assume, were installed, and right now THERE IS a "Screensaver" section in my KDE4 System Settings. Which means, my selection of Fedora™ as my new favourite among the vast Linux distro family is no mistake. I like it and have now switched to it from OpenSuSE™ for everyday use.

And in case someone should face the same situation, mark ye this:
(file) ~/.xscreensaver: (line) lock: False/True. Which is self-explanatory.

CONCLUSION:
GUI is great, but in LINUX one must not expect them to always work the way they should. This is my painful experience. So, don't forget about the very first principle of Linux - use man.

And next time I'll publish some other brilliant solution I have found during my long time usage of Unix OS's.
Posted in Uncategorized
Views 2110 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement

Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration