LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Blogs > gegechris99
User Name
Password

Notices

Rate this Entry

HOW-TO KMyMoney with XFCE desktop on Slackware 14.0 (32-bit edition)

Posted 11-18-2012 at 04:54 AM by gegechris99
Updated 11-18-2012 at 09:26 AM by gegechris99

Hello,

With the recent release of Slackware 14.0, I switched my desktop from KDE to XFCE. Don't get me wrong, I like KDE but it's starting to feel a bit slow on my main laptop (Acer Aspire 7220: AMD Semprom 3500+ 1.8 GHz - RAM 4GB DDR2).

I didn't upgrade from my previous OS (Salix 13.37), but rather made a clean installation. Because I'm using Kmymoney to manage my personal finances and I didn't want to install all the KDE packages just for that application, I made a little bit of research.

I'm pleased to share here how I proceeded to make Kmymoney work with a "minimum" number of KDE packages.

1) Install kmymoney and its dependencies:

I installed the following packages from kde/ and kdei/ series:

kde/kdelibs-4.8.5-i486-1
kde/kdepimlibs-4.8.5-i486-1
kde/oxygen-icons-4.8.5-i486-1
kdei/kde-l10n-fr-4.8.5-noarch-1 - I'm french

Using sbopkg (a tool to automatically download, build and install a Slackware package), I installed the following packages:

libraries/libalkimia-4.3.2-i486-1_SBo
office/kmymoney-4.6.3-i486-1_SBo

2) Prepare the configuration files:

I reinstalled my Kmymoney configuration file that I backed up before installing Slackware 14.0: ~/.kde/share/config/kmymoneyrc

To get French settings for date, number, monetary symbols, I created file ~/.kde/share/config/kdeglobals with the following content (append this content to the file if it already exists):
Code:
[Locale]
Country=fr
DateFormat=%A %d %B %Y
DateFormatShort=%d-%m-%Y
DecimalSymbol=,
Language=fr
MonetaryDecimalSymbol=,
MonetaryThousandsSeparator=
NegativeMonetarySignPosition=1
NegativePrefixCurrencySymbol=false
PositiveMonetarySignPosition=1
PositivePrefixCurrencySymbol=false
ThousandsSeparator=
3) Modify pinentry symlink

My Kmymoney file is encrypted using gpg, so a pinentry dialog box shows up when I start kmymoney.

The first time I tried to open my file, I couldn't enter the passphrase in the pinentry dialog box. As I'm using scim, I remembered that on previous releases, there was a conflict with scim and pinentry. In fact, the last reminder about this issue is available in the CHANGES_AND_HINTS.TXT of 13.1 (but not in the next releases):
Quote:
If you are using the pinentry-gtk2 interface (for entering passphrases with
gpg-agent), be aware that there is a bug in the way scim-bridge and the
pinentry-gtk2 interact. The result is that keyboard input does not register
with pinentry-gtk2. For the time being, either change the /usr/bin/pinentry
symlink to use the qt or curses frontend, or don't use scim.
So as user root, I did:
Code:
cd /usr/bin/
rm pinentry
ln -s pinentry-qt pinentry
And that's all folks.
Posted in Uncategorized
Views 1811 Comments 1
« Prev     Main     Next »
Total Comments 1

Comments

  1. Old Comment
    Thanks for this...really useful.

    It worked fine on my Slackware64 14.0 setup just as well (parts 1 & 2 anyway, I didn't need part 3).

    regards,
    rkfb
    Posted 07-21-2013 at 04:14 PM by rkfb rkfb is offline
 

  



All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration