LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Blogs > gabim
User Name
Password

Notices

Rate this Entry

xorg 1.6.1 surprises

Posted 06-11-2009 at 07:05 PM by gabim
Tags slackware

After upgrading to xorg 1.6.1, I noticed that my hungarian layout of keyboard switched off at the KDM login.
I checked the xorg.conf, but the
Code:
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "hu"
was still there.
I checked the /var/log/Xorg.0.log also and noticed some warnings and errors, mainly the "AllowEmptyInput" warning that it is enabled and will ignore my keyboard definition. Wow!

I set it to false and I surprised again at the KDM login: my keyboard was hungarian, but typed rapidly 3 characters instead of one!

After a little googling I found the solution:
Code:
Section "ServerFlags"
    Option "AllowEmptyInput" "false"
    Option "AutoAddDevices" "false"
EndSection
Now everything is correct.
Posted in Uncategorized
Views 1514 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 01:27 PM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration