LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices



Reply
 
Search this Thread
Old 03-28-2005, 08:51 PM   #1
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
why is X slow to start?


I'm running Arch on my laptop and desktop. There's no problem on the laptop, but I'm having problems with X on the desktop.
It takes a long time for X to start after "startx", and it takes a long time for applications to open once I'm in X. I know this may be a problem with my network, but for now the desktop and laptop are sharing the same router via ethernet. til I can get the wireless working on the laptop, so they have very similar settings except that the ip addresses and modules are different, but I don't think I've missed anything obvious in this regard.
I get a strange warning after shutting down X. This has only been happening (the warning) since I installed fluxbox-devel 0.9.12-2 so I don't know if it's related to the sluggish X behaviour or not (I think not though), but here it is;

*** WARNING: 'Workspace<n>' actions are deprecated! Use 'Workspace <n>' instead

I'm assuming this is related to ~/.fluxbox.init though I'm not sure how.

Any hints for getting X to start quicker and execute programs more quickly once open are much appreciated.

Thanks
 
Old 03-29-2005, 06:32 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
what kind of processor load is your system under with this? what spec is the machine?

the fluxbox error is totally unrelated btw.
 
Old 03-29-2005, 08:14 AM   #3
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Original Poster
Rep: Reputation: 30
Can you explain how I should assess the processor load while the X server is starting up?

For a while last night, it seemed to kick into gear, the programs opened quickly and I was able to open X quickly. I couldn't think what might have caused this, but when I rebooted the box, everything was back to its bad normal self again. I'm thinking this is network related as I'm having a hard time using pacman as well. It seems to be always slow - this may be because I don't have good mirrors set up, I'll check that later.

My pertinent specs are as follows

Dell Dimension 8200
Pentium IV 1.8 GHz
256 MB RAM
10/100 PCI fast ethernet NIC (runs off the tulip module)

Connection through DSL via NAT router setup with static IP address assigned by the router.

Cheers and thanks
 
Old 03-29-2005, 08:19 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
while you run X, run "top" in a console to see where the CPU is being used up, assuming that it is the CPU being whopped by something that's slowing things down. also look at "free" to see how your RAM is being used up.
 
Old 03-29-2005, 06:35 PM   #5
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Original Poster
Rep: Reputation: 30
ok, I managed to correct the problem and it wasn't too difficult to do.
when setting up /etc/rc.conf, I had given a name to HOSTNAME, but had forgotten to edit /etc/hosts. As a result, X was looking for an invalid hostname. Things seem to be back on track now. At least I got to find out about "free" and "top". Very useful. Thanks!
 
Old 04-21-2005, 09:19 AM   #6
wrytin
LQ Newbie
 
Registered: Apr 2005
Location: Cantong
Distribution: arch
Posts: 3

Rep: Reputation: 0
Quote:
Originally posted by dcdbutler

when setting up /etc/rc.conf, I had given a name to HOSTNAME, but had forgotten to edit /etc/hosts. As a result, X was looking for an invalid hostname. Thanks!
I made the same mistake! now i have solved this problem.thank you!
 
Old 04-21-2005, 10:17 AM   #7
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Original Poster
Rep: Reputation: 30
That's cool.
Enjoy Arching
Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM
openoffice slow to start cgoerner Linux - Software 4 08-07-2004 07:32 PM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 02:55 PM
slow kde start netmaniac Linux - Software 6 08-14-2003 04:16 PM
Sendmail is so slow to start! echid Linux - Software 3 05-03-2002 05:58 PM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration