LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 06-30-2006, 04:39 PM   #1
MasterOfTheWind
Member
 
Registered: Jul 2004
Distribution: Arch, Debian sid, Kubuntu, Slackware 11
Posts: 324

Rep: Reputation: 30
Special characters are not displayed


Hi!

Just downloaded and installed Arch linux. Everything works like a charm and I just can't stop loving the lightweightness of this distro. I keep getting this one annoying problem though. I'm using a norwegian keyboard, but I can't get KDE to display the special characters correctly. When I press a key which should be mapped to one such character, I just get two empty boxes - as if the font I'm using does not include these characters. But when running KCharSelect, I am able to verify that they are supported by the font. In addition to this I am successfully using the same font on another system (Debian sid). The font is Sans Serif by the way.

I also tried using other fonts, but with no luck; the same problem occurs also then. It seems like those keys are mapped to wrong characters or something like that....

Does anyone knows what could be wrong, how to fix it or how to remap the special sharacter keys?

Thanks
 
Old 06-30-2006, 10:26 PM   #2
silverw
LQ Newbie
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 5

Rep: Reputation: 0
Hey. A good test of exactly what the problem is would be to see whether a terminal is capable of displaying those characters, because the keyboard might be a separate problem. You could find a text file in that language, save it to your computer, and cat it on a kde terminal or view it in kwrite or something. It probably still won't display correctly--if it doesn't, one thing that might help is changing your locale.

Edit /etc/locale.gen, uncommenting out whatever region code corresponds to norway (preferably, the utf-8 version), then running /usr/sbin/locale-gen. I don't use KDE, so I don't know how KDE keyboard configuration works, but I select my X keyboard by running "xorgconfig" on the command line and generating a xorg.conf file. If I already have a working config file, I just compare and copy the keyboard section to the file I'm currently using. The command to change an X keyboard on the fly is "setxkbmap", but you need to know the name of the keyboard setup--you can see the various keyboard setups in /usr/share/kbd/keymaps/i386/*/ if you are using the latest version of xorg on arch linux.

Hope some of this helped.

Last edited by silverw; 06-30-2006 at 10:31 PM.
 
Old 07-01-2006, 02:31 AM   #3
MasterOfTheWind
Member
 
Registered: Jul 2004
Distribution: Arch, Debian sid, Kubuntu, Slackware 11
Posts: 324

Original Poster
Rep: Reputation: 30
Thanks, I tried to enable the norwegian locale, but that didn't help.

The problem seems though to be a KDE related one. For example KDM (KDE login manager) works fine and displays all the characters perfectly. The same can be said about Firefox. But the native kde applications are still not displaying the special characters correctly.

And even more weird is the fact that when I write something in Firefox (with special characters) then copy and paste it into a kde application, everything works and the characters are displayed beautyfully. But when I press the key corresponding to the special character, it displays only the two empty boxes. So again, it seems like kde applications associate the keystroke with a wrong character.

I still haven't figured out how that can be fixed though
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Special Characters SimeonV Suse/Novell 14 07-07-2006 01:29 PM
international characters are not displayed in FireFox thisObject Linux - Software 13 04-19-2006 11:12 AM
special characters greenbox Linux - Software 9 12-23-2005 07:33 PM
Special characters consty Programming 3 08-07-2005 05:53 AM
NTFS - files with CE font characters not displayed? zocy Mandriva 1 02-08-2004 10:56 PM


All times are GMT -5. The time now is 04:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration