LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices



Reply
 
Search this Thread
Old 10-22-2012, 11:07 AM   #1
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Rep: Reputation: 1
Post Set system language to spanish and set time of the system correctly.


Greetings folks. Today I have two things I want to solve on my freshly installed Arch system.
First something I consider you need to know about my system is that I installed the KDE desktop environment and now to the point.
I would like to know if is there a package that can be installed to set the whole system to the spanish language or how to add it to the locale and set it as default.
Another thing I want to correct is the time of the system, it happens that everytime I restart the system it goes two hours back and I have to manually set it and I think it is because I setted the time to UTC, now I need to set the time manually and get rid of the UTC thing (if it is even possible).

That's all the information I posses right now, if any extra information is required just let me know.
Thank you for your time and in advance, thank you, any help will be very appreciated.
 
Old 10-23-2012, 04:30 AM   #2
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Rep: Reputation: 33
Quote:
Originally Posted by nando321 View Post
Greetings folks. Today I have two things I want to solve on my freshly installed Arch system.
First something I consider you need to know about my system is that I installed the KDE desktop environment and now to the point.
I would like to know if is there a package that can be installed to set the whole system to the spanish language or how to add it to the locale and set it as default.
Another thing I want to correct is the time of the system, it happens that everytime I restart the system it goes two hours back and I have to manually set it and I think it is because I setted the time to UTC, now I need to set the time manually and get rid of the UTC thing (if it is even possible).

That's all the information I posses right now, if any extra information is required just let me know.
Thank you for your time and in advance, thank you, any help will be very appreciated.
To set the time, you have to specify correct time zone ans pointed out in archlinux wiki:
Quote:
Time Zone

Be sure that /etc/localtime is linked to the correct zone file. This is necessary not only for the localtime to be set correctly but also for other
programs you may use. You can do this by:
$ ls -l /etc/localtime

You can find the time zones listed in /usr/share/zoneinfo/ and then you will need to find a major city that exists to your time zone. If you live
in a specialized time zone area these will be listed in sub-directories.

To change your time zone, link /etc/localtime to the new zone file:
# ln -sf /usr/share/zoneinfo/<Zone>/<SubZone> /etc/localtime

Example:
# ln -sf /usr/share/zoneinfo/America/Chicago /etc/localtime

When you set the hardware clock the new time zone will be used; you can check your system's hardware clock within your BIOS.
To set the language you have to enable the necessary locale first, as pointed out in archlinux wiki:
Quote:
Enabling necessary locales

Before a locale can be used on the system, it has to be enabled first. To list all available locales, use:
$ locale -a

To enable a locale, uncomment the name of the locale in the file /etc/locale.gen. This file contains all the available locales that can be used
on the system. Revert the process to disable a locale. After the necessary locales are enabled, the system needs to be updated with the new locales:
# locale-gen

To display the locales now currently in use, use:
$ locale
Tip: Though it's most likely that just one language is used use on your computer, it can be helpful or even necessary to enable other locales as well. If you're running a multi-user system with users that do not speak en_US, their individual locale should at least be supported by your system.
US English example

First uncomment the following locales in /etc/locale.gen:
en_US.UTF-8 UTF-8

Then update the system as root:
# locale-gen
In short: read this (https://wiki.archlinux.org/index.php/Locale) and this (https://wiki.archlinux.org/index.php/Time)
 
Old 10-24-2012, 11:30 AM   #3
nando321
Member
 
Registered: May 2011
Distribution: Slackware
Posts: 76

Original Poster
Rep: Reputation: 1
Hi all. I also looked for help at the archlinux forum and had some extra help.
Now I've got everything set properly and here are the solutions:

Solution for the time: right click over the clock on the panel and go to "Preferences of the Digital Clock". In the window that pops up go to "Time zones" and search for "Default configuration of the clock" and set it to "UTC" and check in on the list your City/Country and UTC as well.

Solution to have the system in spanish language: go to the terminal and login as root, then type "pacman -S kde-l10n-es" and press Enter, wait until the package is downloaded and installed, go to "System Preferences" and find "locale", once there on the "Language" tab select "Spanish" and click on the arrow to send Spanish to prefered language, click "Apply" restart your system and the next time you login to your system the language will be set to spanish.

And that's it. Thank you everyone for your support.
This thread is now solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I tell if my basic linux system is set up correctly? pantherlehr Linux - Newbie 4 07-25-2008 11:56 PM
Where does RH8 daily set system time to hardware clock time smartnorman Red Hat 1 05-24-2006 03:42 PM
why isnt AGPFastWrite Woring on my nvidia system (all seems to be set-up correctly) qwijibow Linux - General 1 10-06-2005 03:29 PM
How can I re-set up default language for my system? backpacker Linux - Newbie 6 06-28-2005 05:07 AM
set system time xushi Slackware 3 03-31-2005 09:56 AM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration