LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices



Reply
 
Search this Thread
Old 11-13-2009, 06:37 PM   #1
cantab
Member
 
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Rep: Reputation: 102Reputation: 102
Screen goes blank after ten minutes (in LXDE), how to change this?


I'm using LXDE on Arch, and the screen blanks after ten minutes of inactivity. I'm not sure if it's screensaver or power management. How do I change this behaviour?
 
Old 11-13-2009, 08:22 PM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Probably your screensaver. Check settings
 
Old 11-15-2009, 09:04 AM   #3
cantab
Member
 
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Original Poster
Rep: Reputation: 102Reputation: 102
I don't know where the screensaver settings are though. I search for 'screensaver' on the Arch Wiki and didn't find anything that seemed relevant.
 
Old 11-28-2009, 03:21 PM   #4
RoboRecht
LQ Newbie
 
Registered: Sep 2009
Location: Belgium
Distribution: Slackware
Posts: 4

Rep: Reputation: 2
It's X

X itself puts on this screensaver by default. You can check this with xset q. To disable, type

bash:$ xset s off

X also automatically puts your pc in standby after 20 minutes or something, and it puts it into hibernate after 30. It would turn it off after 10 more minutes if it could. To disable this too, type:

bash:$ xset -dpms

You can do this automatically when you log in successfully by putting these lines in ~/.xsessionrc:

robo@anonymous:~$ cat .xsessionrc
# turn off default screensaver
xset s off
# turn off default standby, hibernate, ... after n minutes
xset -dpms
robo@anonymous:~$

The screen still goes blank after 10 minutes before you login, in gdm. But that doesn't bother me.

This was probably put in because of people with old monitors, that can have images burnt in to them. Or for energy saving purposes. Still a pain in the ass, though.

You can put it in Xorg.conf too : http://www.shallowsky.com/linux/x-screen-blanking.html

Greetings,

Last edited by RoboRecht; 12-10-2009 at 03:54 PM. Reason: found a good reference
 
1 members found this post helpful.
Old 03-19-2010, 02:01 AM   #5
randomx
Member
 
Registered: Feb 2003
Location: Hawaii
Distribution: Debian
Posts: 130

Rep: Reputation: 16
Wink

it's 2010 but hopefully it saves time to somebody else.

Code:
xset s noblank
Code:
xscreensaver&
and make sure your screensaver doesn't kick in until 10 hours later or simply disable it.
 
Old 03-27-2010, 05:49 AM   #6
xamaco
LQ Newbie
 
Registered: Sep 2009
Location: Bastelicaccia, Corsica
Distribution: Crux
Posts: 15

Rep: Reputation: 3
Try running xscreensaver-demo. If your system is using xscreensaver, it will let you configure the screensaver itself and power management.
 
Old 03-27-2010, 12:31 PM   #7
cantab
Member
 
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Original Poster
Rep: Reputation: 102Reputation: 102
Belatedly marked this thread solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 12beta LXDE blank screen on startup Live CD Timmi Fedora - Installation 0 11-06-2009 06:06 PM
Blank screen in CLI after a few minutes Jeebizz Slackware 3 02-21-2006 08:51 PM
Blank screen after 10-12 minutes on Debian kushalkoolwal Debian 1 02-02-2006 12:10 PM
Blank screen after 10 minutes (have tried alot) Ephracis Slackware 6 09-21-2004 02:37 AM
Screen goes blank after about 10 minutes jmax24 Linux - General 3 04-19-2004 09:05 PM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration