LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2010, 02:20 PM   #1
TheStarLion
Member
 
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Rep: Reputation: 41
PulseAudio not appearing in gstreamer-properties


I noticed a few packages starting to depend on libpulse, part of pulseaudio and decided to give the full pulseaudio a try.
So I've used Arch's wiki to install and set up pulseaudio in a Gnome environment, and it works. Sort of.
The wiki states that to correctly have audio played through it, I have to choose PulseAudio in 'gstreamer-properties'

PulseAudio doesn't appear in there at all, and running gstreamer-properties from the terminal announces that it is unavailable and being skipped.
There used to be a gstreamer-pulse package, but this is now apparently outdated and is no longer available.
I've managed to 'fix' this by setting the variables directly with gconftool, but I'm not the only user on this computer and I don't want someone else to go fiddling and change it to the wrong setting just because it doesn't display anything.
 
Old 11-30-2010, 05:46 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Did you remove gnome-media & gnome-settings-daemon and install gnome-media-pulse & gnome-settings-daemon-pulse?
Try that and then run
Code:
gstreamer-properties
 
Old 11-30-2010, 10:31 PM   #3
TheStarLion
Member
 
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Original Poster
Rep: Reputation: 41
Yes.
No difference is made. Running gstreamer-properties via terminal still tells me the pulse options are unavailable - though having set the options through the gconftool, applications still use pulseaudio instead.
 
Old 12-01-2010, 07:37 PM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
When I run gstreamer-properties in the terminal, it opens up multimedia systems selector. Pulseaudio is unavailable for plugin selection for you?

Last edited by andrewthomas; 07-15-2011 at 02:30 PM.
 
Old 12-02-2010, 04:40 AM   #5
TheStarLion
Member
 
Registered: Nov 2009
Location: UK
Distribution: Gentoo
Posts: 472

Original Poster
Rep: Reputation: 41
That's the same dialog I get, but the terminal output also lists 'pulsesink' and 'pulsesrc' as unavailable, which in turn causes it not to display the PulseAudio option in the GUI.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pulseaudio and jack davebritton Linux - Software 1 09-07-2010 03:45 PM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 08:30 AM
Anyone using pulseaudio? Daedra Slackware 14 04-15-2010 02:10 PM
[SOLVED] gstreamer-plugins-base conflicts with gstreamer-plugins-good Raveolution Linux - Software 14 11-17-2009 01:24 PM
Pulseaudio RAFAL Linux - Software 7 08-23-2008 04:37 PM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration