LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 10-24-2012, 07:08 AM   #1
heolstor
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Rep: Reputation: Disabled
Post installation issues and laptop Acer Aspire 5830g


Hi everyone,

For the past 2 days i was trying to get Arch Linux x64 running on my laptop. The relevant specs are: corei5 processor, 4gb ram, and geforce 540m gpu.

I installed Arch from an usb stick following the "Beginners Guide" from its official wiki.

Everything went good with the install up to the point where i needed to reboot and start using the actual system.
After the reboot, Grub loaded up Arch repo kernel (i have to mention i am dual-booting with Windows) and the system greeted me with the following message:

Code:
[   6.926523] [drm] mouveau 0000:01:00.0: 0xD518: i2c wr fail: -6
And then it hangs for about 3 minutes, after that displaying this message:
Code:
Welcome to the emergency mode. Use "systemctl defaul" or ^D to enter default mode.
Give root password for maintenance
Pressing ^D only lets the system hang for 2 more minutes and then the message right above appears again.

If i log in as root and check the partition list with "lsbk" it appears that only the root partition is mounted, while i created and mounted a /boot partition as well during the install.

My wired internet connection is down as well and no matter wthat steps i tried from the arch wiki, i can't bring it up.

I think there are 2 things that i must've messed up during the installation. As the internet connection and partitions were displayed correctly.

As i installed fro and usb stick, the arch install was reading my usb as /dev/sda and the HDD as /dev/sdb. And i mounted the partitions as /dev/sdbX accordingly. Maybe now its giving me issues because it cannot find all those sdb partitions since grub reads them as sda.

Secondly, i changed my hostname during the installation (as it suggested) but i used a name which started with an uppercase letter and i cannot help but wonder if that was the problem or there were some additional settings i must have missed.

Can anyone help me with this please?

Sorry for the long post and let me know if there is any more info you may need

Thanks in advance
 
Old 10-28-2012, 10:11 AM   #2
heolstor
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
I have tried installing Arch again, in case i missed something important the last time but it's the same old story. Internet doesn't work after i reboot after the installation, and the /boot partition isn't mounted as well. Tried enabling any of the wired internet processes like dhpcp to no avail.

Do you think some of those issues may be caused because i installed from a usb drive? Is installing from a cd/dvd "safer"?
 
Old 10-31-2012, 08:19 PM   #3
Lone_Wolf
Member
 
Registered: Jul 2007
Location: Netherlands
Distribution: Archlinux x86_64
Posts: 48

Rep: Reputation: 20
It looks as though your system changes the order of drives depending on where it's booting from.

That means you either have to change the grub boot file manually, or install from cd/dvd .


The hostname with uppercase letter shouldn't make a difference.
As for the problems with internet : this is possibly caused by the lack of the initramfs upon booting due to the problems with the grub settings.
 
Old 11-01-2012, 06:47 AM   #4
heolstor
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks for the reply.
As far as i understand the root of all problems should be the usb install, i haven't tried yet to install from a cd but i will surely update the thread when that happens.
I am quite new to linux and maybe i went in over my head, however i will keep trying.
 
Old 11-03-2012, 02:46 PM   #5
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
The original problem is likely a result of installing GRUB on the wrong drive. Are you dual booting with two separate drives and, if so, which drive has which OS? And which drive did you have GRUB install to?

I doubt the problem lies in the USB installation.
 
Old 11-03-2012, 03:14 PM   #6
heolstor
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
I have only one harddisk in my laptop, when installing Arch the lsblk command listed the USB drive as sda and the rest of the harddisk partitions as sdbX. When installing GRUB i chose the partitions accordingly, though i have chosen the automatic config as i didn't know well how to configure it manually.

After restarting and removing the USB, i chose Arch Linux from GRUB and the system booted into the command line interface, displaying the errors i mentioned in the first post.

However when listing partitions, although i did not see the /boot partition displayed, the root partition was listed as /sdaX, and it was the correct partition. Mounting /boot again into the partition i assigned during install did not help.

I also searched for any GRUB configuration files but couldn't find anything relevant to change in there
 
Old 11-03-2012, 05:43 PM   #7
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
So when you installed grub you installed to /dev/sdb? I would not have expected your usb drive to show up as /dev/sda...? Maybe someone else is familiar with this. When I installed I had Windows on /dev/sda and Arch on /dev/sdb. I first installed grub to /dev/sdb and got the same message you had. I reinstalled grub to /dev/sda and the problem was resolved.
 
Old 11-03-2012, 06:13 PM   #8
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
I take back my last post! If I remember correctly, what I did to fix the problem was follow the steps for setting the clock in Windows to UTC. Follow this guide, as provided in the Arch Beginners Guide.

https://wiki.archlinux.org/index.php...UTC_in_Windows

That should fix your boot problem.
 
1 members found this post helpful.
Old 11-07-2012, 07:11 AM   #9
heolstor
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
After installing from a CD and changing the clock to UTC in Windows Arch booted up nicely. Thanks for all the replies
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer Aspire 5732 Z, newer distobutions and Display post POST katobe62 Linux - Laptop and Netbook 2 08-16-2012 10:26 AM
Installation of Linux on Acer Aspire 5502NWXMi laptop oryxz Linux - Laptop and Netbook 4 09-08-2005 04:19 PM


All times are GMT -5. The time now is 09:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration