LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 07-05-2011, 07:40 PM   #1
benc1213
LQ Newbie
 
Registered: Apr 2011
Distribution: Arch x86_64
Posts: 20

Rep: Reputation: 0
Openbox won't show cursor


I installed xcompmgr and added:
xcompmgr -fF -I-.002 -O-.003 -D6
to the autostart.sh file and now I cannot see a cursor and I cannot right click to get the menu? How do I fix this? I even went into fallback mode and it gave me the same thing.
 
Old 07-05-2011, 10:48 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,712
Blog Entries: 1

Rep: Reputation: 221Reputation: 221Reputation: 221
Stop using xcompmgr. It's a proof of concept application and was never intended for day to day use. Have you checked the Arch Wiki to see if there is a better choice for compositing a window manager like Openbox? Something like Cairo Compmgr might be a better choice.

Of course, it might be simply that you forgot to add the ampersand (&) to the end of the xcompmgr line in autostart.sh. Doesn't change my advice to stop using it though.
 
Old 07-05-2011, 11:23 PM   #3
benc1213
LQ Newbie
 
Registered: Apr 2011
Distribution: Arch x86_64
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks but I can't even right click to go the the menu to open up my terminal. Any way I can open the terminal without the mouse?
 
Old 07-06-2011, 12:14 AM   #4
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,712
Blog Entries: 1

Rep: Reputation: 221Reputation: 221Reputation: 221
I'm not an Arch user, so I'm not familiar with their configuration. Here are some things you can try that work on all of my machines.

- I don't think there is a default keybinding in Openbox for the menu, but you could try the Windoze or the menu key.
- Kill your X server (Ctrl-Alt-Backspace) and you'll be in a terminal. Ctrl-Alt-Backspace may be disabled.
- Ctrl-Alt-F1 will open a new tty for you to login.
- Reboot the machine and temporarily edit the kernel line in the GRUB configuration. When you're booting and you get the GRUB menu, follow the instructions GRUB provides for allowing you to edit the config before you boot. At the end of the line that start with kernel add a space and the number 3. This will cause you to boot into run level 3.
 
Old 07-06-2011, 03:30 PM   #5
benc1213
LQ Newbie
 
Registered: Apr 2011
Distribution: Arch x86_64
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks weibullguy I was able to fix it.
 
Old 07-06-2011, 05:17 PM   #6
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,712
Blog Entries: 1

Rep: Reputation: 221Reputation: 221Reputation: 221
If you mark it as SOLVED it would be the FLOSS way to tell everyone HOW it was solved.
 
Old 07-06-2011, 11:38 PM   #7
benc1213
LQ Newbie
 
Registered: Apr 2011
Distribution: Arch x86_64
Posts: 20

Original Poster
Rep: Reputation: 0
Sure of course. Ok well all I did was do Ctrl-Alt-F1 and edit the autostart.sh file. It was missing the & at the end but to effects were annoying anyways so I removed it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Openbox autostart.sh and setting alias on openbox start Jelloir Linux - Desktop 1 07-03-2011 03:56 AM
[SOLVED] tint won't work in openbox on a 12.2 box charlie_lab Slackware 4 09-03-2009 08:04 AM
[SOLVED] Show desktop exemption for specific window in openbox mmatt Linux - General 8 07-25-2009 08:28 AM
vncserver in Ubuntu 7.04 show only black background and a cursor, nothing more! lawrence_lee_lee Ubuntu 1 09-24-2007 09:41 PM
Please help - Can't get selection cursor to show up in Konqueror... Contrast Linux - Software 1 01-26-2007 05:07 AM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration