LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 05-21-2006, 03:18 PM   #1
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
Open Office wont start


Ok so i was on a roll today, got Alsa all set up, and wine with a few games.

Then i went for open office, figured it'd be simple, did a

Code:
pacman -S openoffice-base
It went along and installed it all, even put the menus in the KDE one.

However when i go to run it (the main app or any individual ones) from the menu i get "The application cannot be started, an internal error has occured"

And the command line output is "I18N: Operating system doesn't support locale "" "

Now the only reference i know of to locale is in the /etc/rc.conf and i have tried setting this to en_GB and en_US and i stil lget this error. I was following hte instructions from here:

http://wiki.archlinux.org/index.php/OpenOffice but it makes no mention of errors. I dont think it's a java problem as i have that installed and configured and running for other programs.

Any help would be most appreciated
 
Old 05-22-2006, 08:49 AM   #2
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,
could you post the output of
Code:
locale
regards,
slackie1000
 
Old 05-22-2006, 07:04 PM   #3
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Original Poster
Rep: Reputation: 45
Code:
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
So i then did
Code:
export LC_ALL=en_US
and still no dice.

Open office works under root though, the permissions of /opt/openoffice/program/soffice are -r-xr-xr-x

Last edited by ethics; 05-22-2006 at 07:06 PM.
 
Old 05-23-2006, 02:04 AM   #4
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,
you need to compare locale's output between users:
root and your_user.
should be a difference between.
the error message does not concern any permission issues.
regards,
slackie1000
 
Old 05-23-2006, 04:41 PM   #5
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Original Poster
Rep: Reputation: 45
locale under root:

Code:
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
locale under user:
Code:
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
They are identical
 
Old 05-24-2006, 01:55 AM   #6
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,
did you read this ?
the wiki has also some tips.
hope it helps.
regards,
slackie1000
 
Old 05-24-2006, 07:12 PM   #7
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Original Poster
Rep: Reputation: 45
Hmmm odd, i did it a few times before it worked, removing the .openoffice.org2 directory but it worked nontheless thank you very much slackie
 
Old 05-25-2006, 04:17 AM   #8
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,
you are welcome!
regards,
slackie1000
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Add open office to start menu tjgadu Linux - Newbie 5 12-02-2005 03:41 AM
Open Office won't start. dwig365 Linux - Software 0 12-10-2004 03:47 PM
Open Office spellchecker just wont work!! nmares Linux - Software 2 09-12-2004 01:42 AM
how to start open office? santasballz Linux - Newbie 3 03-09-2004 07:23 AM
how do u start open office bosewicht Linux - Newbie 1 12-29-2003 05:12 PM


All times are GMT -5. The time now is 05:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration