LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 10-06-2009, 02:41 PM   #1
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Rep: Reputation: 18
No sound in Arch


I am currently in the last steps (I really hope) of creating my first Arch system. However I have come into a problem. I was able to configure the sound in Arch and succesfully tested it before I installed the KDE desktop. I looked at this website: and tried the suggested steps.

It removed
Quote:
The audio playback device <name-of-the-sound-device> does not work. Falling back to default
error message I was getting, however I still do not have any sound. When I try and play an audio or video file it appears to play without any error messages, but no sound comes out.

I double checked with alsamixer to make sure that the volume wasn't muted, apart from that I am out of ideas.

However when i tried to open the application KMix it simply span for a while and the shut, the command used by the menu icon to open it is
Quote:
kmix -caption "%c" %i
however when I put this into the command line I get:
Quote:
kmix: Unexpected argument '%i'.
kmix: Use --help to get a list of available command line options.
If I simply use kmix I receive:
Quote:
<unknown program name>(2035)/: KUniqueApplication: Cannot find the D-Bus session server: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

<unknown program name>(2034)/: KUniqueApplication: Pipe closed unexpectedly.
ps I am usually a Gnome user, this is my first attempt at KDE so if this is a dumb mistake then please accept my apologies and many thanks in advance.

Is there a gstreamer-properties equivalent command in KDE
 
Old 10-06-2009, 03:30 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,465
Blog Entries: 3

Rep: Reputation: 184Reputation: 184
in kde click the menu launcher "k" > computer > System Settings > multimedia > test
if nothing then right click the speaker icon and select mixer Chanel.
If using pulse sound. open a terminal and assume root type alsaconfig then set up your card. then right click your speaker icon and set up your mixer to pcm.
hope this helps. for kde you may have to install esound to use sound for notices.
 
Old 10-06-2009, 03:50 PM   #3
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
Drakeo, thanks for the prompt reply.

When I click on test I hear nothing. I configured the sound card using alsaconf and then set the levels using alsamixer. However when I right click on the speaker I do not get an option to change the mixer to pcm. I can only select CA0106 (sound card) or VF0380 Live Optia Cam Pro (webcam).

The choices I have for the CA0106 are:

Master
IEC958 Center/LFE
IEC958 front
IEC958 rear
IEC958 unknown
Analog Center/LFE
Analog front
Analog rear
Analog side
CAPTURE feedback

Can I use Pulseaudio with KDE? I thought this was a Gnome application.
 
Old 10-06-2009, 11:22 PM   #4
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Do these :
Code:
pacman -S phonon-xine
Then goto Multimedia from system settings and select backend and change to Xine and NOT Gstreamer.

Add
Code:
[archlinuxfr]
http://repo.archlinux.fr/i686 [or x86_64 for 64bit]
to /etc/pacman.conf

Then:
Code:
pacman -Sy codecs-all
 
Old 10-07-2009, 02:57 AM   #5
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
Shylock, thanks for your response.

Quote:
pacman -S phonon-xine
I did this yesterday, but without any success.
Quote:
[archlinuxfr]
http://repo.archlinux.fr/i686 [or x86_64 for 64bit]
When I put this into etc/pacman.conf I get an error message when attempting to download the codecs-all package (should I try this in the mirrorlist file?)
 
Old 10-07-2009, 04:24 AM   #6
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
Sorry, was being daft, double checked and had typed X68_64 at end (D'oh). Installed the codecs, restarted the computer and now don't have a sound card at all. I think I am going to give up on KDE, this was my first advnture I had been warned that it was buggy, but I did not expect to spend over 36 hours simply getting an environment working (still isn't). Thanks for your help folks, however I am going to remove KDE and then install Gnome.
 
Old 10-07-2009, 06:09 AM   #7
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Quote:
Originally Posted by kmacphail View Post
Sorry, was being daft, double checked and had typed X68_64 at end (D'oh). Installed the codecs, restarted the computer and now don't have a sound card at all. I think I am going to give up on KDE, this was my first advnture I had been warned that it was buggy, but I did not expect to spend over 36 hours simply getting an environment working (still isn't). Thanks for your help folks, however I am going to remove KDE and then install Gnome.
kmacphail

KDE4.3.2 was just released in extra. KDE is way better in every way than gnome: better apps, better looks, better response etc. It is your decision in the end but I'd strongly suggest you try to reistall KDE instead of installing gnome. I'd say backup your:

Code:
sudo cp /var/cache/pacman/pkg/*  /destination-drive
So that you can setup your local repo and don't have to redownload the packages next time you think about giving it a shot.
Btw just outta curiousity did you do this:

Code:
gpasswd -a username audio
And reboot?
 
Old 10-07-2009, 09:40 AM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,465
Blog Entries: 3

Rep: Reputation: 184Reputation: 184
I wonder does the user have audio and plugdevices pulse in his group. If you do not have permission for audio and pulse you will never get to use it.
Check your users groups. make sure they have audio and pulse if using pulse in their users group. plugdevice is a must.
k-launcher > applications > system > User Manager then password then click the user and edit his groups if needed.

Last edited by Drakeo; 10-07-2009 at 09:44 AM.
 
Old 10-08-2009, 04:04 AM   #9
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
I did have the permissions, not a problem. It appeared that the problem was the KDE install. I removed KDE and then reinstalled it again and the problem was gone. I didn't install gnome as the whole point of me building this Arch system was to learn more about KDE. I don't actually agree with your statement about KDE, each to their own.
 
  


Reply

Tags
alsa, arch, kde, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arch user wanted to help padawan learner install arch and use it thomas-linuxing Linux - Software 9 10-18-2006 04:02 PM
Arch linux have sound but not in games :S jkh Linux - Games 1 07-14-2005 07:03 AM
questions about sound in arch linux. greythorne Arch 2 06-27-2005 07:26 AM
No sound in Arch Linux, had same problem when upgrading to slack 10.1 landfill Linux - Hardware 11 06-25-2005 01:45 PM
Sound in Arch 0.6 ghight Arch 7 02-29-2004 04:39 PM


All times are GMT -5. The time now is 11:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration