LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 04-07-2012, 05:12 AM   #1
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Rep: Reputation: 279Reputation: 279Reputation: 279
New install issues


Hi gang!

I just did a new install...and all went by the book...except for a little something: I cannot log in.

Install specs: Arch-XFCE4-GDM

I get up to the point where GDM shows, but only as a grey square in the center of the screen. I gave the .xinitrc exec rights, so the script can run. Polkit and consolekit are installed (running?) as well...

What paragraph of the manual did I miss?

Thanks!

Thor
 
Old 04-07-2012, 06:00 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Does it boot correctly to a command line? What happens if you then try to run 'startx' from there? Is there anything in /var/log (particularly /var/log/Xorg* and /var/log/gdm*) ?

Hope this helps,
 
Old 04-07-2012, 06:17 AM   #3
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Original Poster
Rep: Reputation: 279Reputation: 279Reputation: 279
Quote:
Does it boot correctly to a command line? What happens if you then try to run 'startx' from there? Is there anything in /var/log (particularly /var/log/Xorg* and /var/log/gdm*) ?
- it boots correctly to the command line. When i turn GDM off (in /etc/rc.conf) I can log into a usable system
- startx (for the non-root user) gives a black screen - after issuing it from the command line. No way to ctrl-alt into a console to shut down in a contolled manner, a nuke is all option I have then...
- I dont see any errors in the logs

More than likely, I forgot to do some (crucial) setting, after all, how does the GDM even know what user to present? Should'nt I set something to allow it to run, read, or otherwise do something?

Thor
 
Old 04-07-2012, 08:31 AM   #4
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Lightbulb

PLease post

/etc/rc.conf
/home/user/.xinitrc

You need to make sure dbus is loaded prior to gdm ( I use slim) and you launch through .xinitrc. Sample lines below from mine.

I have seen some users not do this which drives similiar issues.

Code:
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
# If something other takes care of your hardware clock (ntpd, dual-boot...)
# you should disable 'hwclock' here.
#
DAEMONS=(hwclock syslog-ng dbus nnetwork networkmanager sshd cupsd netfs crond alsa slim)

---------------

!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

# exec gnome-session
# exec startkde
exec ck-launch-session dbus-launch startxfce4

exec ck-launch nm-applet &
 
Old 04-07-2012, 02:40 PM   #5
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Original Poster
Rep: Reputation: 279Reputation: 279Reputation: 279
Hi

Thanks for this info...by the way, I just moved to Slim, but I cannot type anything...maybe a helpful hint...

rc.conf

Quote:
#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# DAEMON_LOCALE: If set to 'yes', use $LOCALE as the locale during daemon
# startup and during the boot process. If set to 'no', the C locale is used.
# HARDWARECLOCK: set to "", "UTC" or "localtime", any other value will result
# in the hardware clock being left untouched (useful for virtualization)
# Note: Using "localtime" is discouraged, using "" makes hwclock fall back
# to the value in /var/lib/hwclock/adjfile
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# Note: if unset, the value in /etc/localtime is used unchanged
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.UTF-8"
DAEMON_LOCALE="no"
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Brussels"
KEYMAP="be-latin1"
CONSOLEFONT="161"
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MODULES: Modules to load at boot-up. Blacklisting is no longer supported.
# Replace every !module by an entry as on the following line in a file in
# /etc/modprobe.d:
# blacklist module
# See "man modprobe.conf" for details.
#
MODULES=()

# Udev settle timeout (default to 30)
UDEV_TIMEOUT=30

# Scan for FakeRAID (dmraid) Volumes at startup
USEDMRAID="no"

# Scan for BTRFS volumes at startup
USEBTRFS="no"

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="Asgaard"

# Use 'ip addr' or 'ls /sys/class/net/' to see all available interfaces.
#
# Wired network setup
# - interface: name of device (required)
# - address: IP address (leave blank for DHCP)
# - netmask: subnet mask (ignored for DHCP) (optional, defaults to 255.255.255.0)
# - broadcast: broadcast address (ignored for DHCP) (optional)
# - gateway: default route (ignored for DHCP)
#
# Static IP example
# interface=eth0
# address=192.168.0.2
# netmask=255.255.255.0
# broadcast=192.168.0.255
# gateway=192.168.0.1
#
# DHCP example
# interface=eth0
# address=
# netmask=
# gateway=

interface=eth1
address=192.168.1.3
netmask=255.255.255.0
broadcast=192.168.1.255
gateway=192.168.1.1

# Setting this to "yes" will skip network shutdown.
# This is required if your root device is on NFS.
NETWORK_PERSIST="no"

# Enable these netcfg profiles at boot-up. These are useful if you happen to
# need more advanced network features than the simple network service
# supports, such as multiple network configurations (ie, laptop users)
# - set to 'menu' to present a menu during boot-up (dialog package required)
# - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
# - prefix a daemon with a ! to disable it
# - prefix a daemon with a @ to start it up in the background
#
# If something other takes care of your hardware clock (ntpd, dual-boot...)
# you should disable 'hwclock' here.
#
DAEMONS=(hwclock syslog-ng dbus udev slim network netfs crond )
and .xinitrc

Quote:
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
for f in /etc/X11/xinit/xinitrc.d/*; do
[ -x "$f" ] && . "$f"
done
unset f
fi

# exec gnome-session
# exec startkde
exec ck-launch-session dbus-launch startxfce4
# ...or the Window Manager of your choice
By the way, I used your examples to get the squirt to breathe, but it's still a dead dodo...

I'm somewhat surprised I cannot type anything in Slim (the better alternative I must confess, thanks for hinting out that one) nor can I switch to an other console...
I have licked that one before, but I'll be d**ed if I remember what I did...maybe I am getting old

Thor

Last edited by Thor_2.0; 04-07-2012 at 02:53 PM.
 
Old 04-07-2012, 03:17 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,566
Blog Entries: 2

Rep: Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035Reputation: 4035
Quote:
Originally Posted by Thor_2.0 View Post
I'm somewhat surprised I cannot type anything in Slim (the better alternative I must confess, thanks for hinting out that one) nor can I switch to an other console...
I had that once with Arch, it was simply because I forgot to install mouse and keyboard drivers for X.
 
Old 04-07-2012, 05:21 PM   #7
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Original Poster
Rep: Reputation: 279Reputation: 279Reputation: 279
Quote:
I had that once with Arch, it was simply because I forgot to install mouse and keyboard drivers for X.
Mhwell...I may have installed more than required (but that's not lethal, here) but still no input. I rearranged the daemons array...udev, dbus and then Slim all the way as last...
I'm beginning to suspect I'm not even in a console.
I just edited the slim.conf, but did'nt find anything of interest...

Oh well, I'm off to snoozeville now!

Sleep tight, world!

Thor
 
Old 04-09-2012, 04:43 AM   #8
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
I would personally start over and retrace your steps compared to the instructions. It would probably be quicker than troubleshooting.

Good luck.
 
Old 04-09-2012, 05:57 AM   #9
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Original Poster
Rep: Reputation: 279Reputation: 279Reputation: 279
Quote:
I would personally start over and retrace your steps compared to the instructions. It would probably be quicker than troubleshooting.
Possibly the best idea...there's nothing to learn here so, I may just either redo the install, or simply give up on Arch for this (difficult) machine and go for Debian instead...
 
Old 04-11-2012, 05:04 PM   #10
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Original Poster
Rep: Reputation: 279Reputation: 279Reputation: 279
Hi,

I can call this solved. The sloution was ... reading the manual more attentively...
I needed to activate KMS (early on, preferably) to make the nVidia card happy...

Solved...

Thanks for bearing with me, gang!

Thor
 
Old 04-12-2012, 04:01 AM   #11
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 718

Rep: Reputation: 102Reputation: 102
Cool .. Another Member of Team Arch
 
Old 04-13-2012, 04:05 AM   #12
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,204
Blog Entries: 23

Original Poster
Rep: Reputation: 279Reputation: 279Reputation: 279
Quote:
Another Member of Team Arch
Yeah!!! I'm happy to have it running, the other ones did'nt give me the level of control I needed (am I getting to be a control freak ??? Nah, it's my Arch-itis acting up again...) so ... yeah!

Team Arch Rules!!!!

Whee!

On a serious note, I needed the partitioning and package selection to be extra-fine-tuned for this particular setup. It's not really a firecracker of a PC (as mentioned Duron just below 1000Mc, 512Mb ram, 80Gb disk and a 6200 nVidia card) so "the works" would possibly have brought the thing to its knees...

Thor

Last edited by Thor_2.0; 04-13-2012 at 04:16 AM.
 
  


Reply

Tags
arch, gdm, install, login


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Issues atmega-ist Linux - Newbie 20 05-02-2010 02:42 AM
Install issues. ChrisR(SQL DBA) Linux - Newbie 2 12-30-2006 10:00 AM
5.10 install issues.. NIC not seen .. cannot finish install StamfordRob Ubuntu 1 02-17-2006 03:34 PM
Install Issues kencyber VectorLinux 4 11-15-2003 09:02 PM
9.1 install issues sebvad Mandriva 2 09-10-2003 07:13 AM


All times are GMT -5. The time now is 04:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration