LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 01-14-2006, 12:12 PM   #1
anti.corp
Member
 
Registered: Nov 2005
Location: Copenhagen
Distribution: Debian E, Vectorlinux 5.1std, Arch, Gentoo 2006.0
Posts: 576

Rep: Reputation: 30
Need to add Danish layout for my keyboard[SOLVED]


Hi,

When I add it in Gnome, it comes up with an error and no changes.

Do I need to edit it in my /etc/rc.conf? And in that case where can I see what to write in it?

Sincerely, Jorgen

Last edited by anti.corp; 01-17-2006 at 12:16 PM.
 
Old 01-14-2006, 07:26 PM   #2
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X
Posts: 488

Rep: Reputation: 31
It would help to know the exact error you get.
I used Desktop--> Preferences--> Keyboard--> Layouts and that worked for me. You can use the KEYMAP field in rc.conf, but I don't use it so I'm guessing you shouldn't need to change that either. There is also an option in Xorg: XkbLayout, maybe you need to change that.
 
Old 01-14-2006, 07:59 PM   #3
AxelFendersson
Member
 
Registered: Mar 2004
Location: Darkest Oxfordshire
Distribution: Arch, Slackware
Posts: 184

Rep: Reputation: 30
If you're just trying to change your keyboard layout globally, replace the line
KEYMAP=us
with
KEYMAP=dk
in /etc/rc.conf , and make sure your /etc/X11/xorg.conf contains the lines
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "dk"

If you haven't already, you might also want to set LOCALE=da_DK and TIMEZONE=Europe/Copenhagen in /etc/rc.conf while you're at it.

If you're just tring to set Danish as an optional alternative layout, I've no idea why the GNOME keyboard options dialog doesn't work for you, as it seems to work fine for me. Sorry.

Last edited by AxelFendersson; 01-14-2006 at 08:00 PM.
 
Old 01-15-2006, 02:45 PM   #4
anti.corp
Member
 
Registered: Nov 2005
Location: Copenhagen
Distribution: Debian E, Vectorlinux 5.1std, Arch, Gentoo 2006.0
Posts: 576

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by JunctaJuvant
It would help to know the exact error you get.
I used Desktop--> Preferences--> Keyboard--> Layouts and that worked for me. You can use the KEYMAP field in rc.conf, but I don't use it so I'm guessing you shouldn't need to change that either. There is also an option in Xorg: XkbLayout, maybe you need to change that.
Yes offcourse.

Here is the message I get when trying to add keyboard layout in Gnome

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd


Thats it.
 
Old 01-17-2006, 12:15 PM   #5
anti.corp
Member
 
Registered: Nov 2005
Location: Copenhagen
Distribution: Debian E, Vectorlinux 5.1std, Arch, Gentoo 2006.0
Posts: 576

Original Poster
Rep: Reputation: 30
Problem is solved.

I did the following;

A clean reinstall using 'km' command to pick Danish keyboard. (earlier i picked default US keyboard layout).

After the install I added/modified the info in my /etc/X11/xorg.conf as AxelFenderson wrote in his reply:
Quote:
If you're just trying to change your keyboard layout globally, replace the line
KEYMAP=us
with
KEYMAP=dk
in /etc/rc.conf , and make sure your /etc/X11/xorg.conf contains the lines
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "dk"
Thats it.
Now I got no errors when Gnome starts, and my keyboard works just as it should be!
Great.

Thanks to you all helping out with this
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
How do I map my keyboard to be able to enter Danish characters ajede Linux - Hardware 1 10-10-2005 12:17 PM
add keyboard layout to kxkb LinuxLala Linux - General 1 06-28-2004 06:18 AM
Danish Keyboard Grimo Linux - Newbie 0 12-16-2003 01:33 PM
Keyboard Layout orlenok Linux - Newbie 2 10-05-2003 09:53 PM


All times are GMT -5. The time now is 05:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration