LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Arch (http://www.linuxquestions.org/questions/arch-29/)
-   -   Need to add Danish layout for my keyboard... (http://www.linuxquestions.org/questions/arch-29/need-to-add-danish-layout-for-my-keyboard-403329/)

anti.corp 01-14-2006 12:12 PM

Need to add Danish layout for my keyboard[SOLVED]
 
Hi,

When I add it in Gnome, it comes up with an error and no changes.

Do I need to edit it in my /etc/rc.conf? And in that case where can I see what to write in it?

Sincerely, Jorgen

JunctaJuvant 01-14-2006 07:26 PM

It would help to know the exact error you get.
I used Desktop--> Preferences--> Keyboard--> Layouts and that worked for me. You can use the KEYMAP field in rc.conf, but I don't use it so I'm guessing you shouldn't need to change that either. There is also an option in Xorg: XkbLayout, maybe you need to change that.

AxelFendersson 01-14-2006 07:59 PM

If you're just trying to change your keyboard layout globally, replace the line
KEYMAP=us
with
KEYMAP=dk
in /etc/rc.conf , and make sure your /etc/X11/xorg.conf contains the lines
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "dk"

If you haven't already, you might also want to set LOCALE=da_DK and TIMEZONE=Europe/Copenhagen in /etc/rc.conf while you're at it.

If you're just tring to set Danish as an optional alternative layout, I've no idea why the GNOME keyboard options dialog doesn't work for you, as it seems to work fine for me. Sorry.

anti.corp 01-15-2006 02:45 PM

Quote:

Originally Posted by JunctaJuvant
It would help to know the exact error you get.
I used Desktop--> Preferences--> Keyboard--> Layouts and that worked for me. You can use the KEYMAP field in rc.conf, but I don't use it so I'm guessing you shouldn't need to change that either. There is also an option in Xorg: XkbLayout, maybe you need to change that.

Yes offcourse.

Here is the message I get when trying to add keyboard layout in Gnome

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd


Thats it.

anti.corp 01-17-2006 12:15 PM

Problem is solved.

I did the following;

A clean reinstall using 'km' command to pick Danish keyboard. (earlier i picked default US keyboard layout).

After the install I added/modified the info in my /etc/X11/xorg.conf as AxelFenderson wrote in his reply:
Quote:

If you're just trying to change your keyboard layout globally, replace the line
KEYMAP=us
with
KEYMAP=dk
in /etc/rc.conf , and make sure your /etc/X11/xorg.conf contains the lines
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "dk"
Thats it.
Now I got no errors when Gnome starts, and my keyboard works just as it should be!
Great.

Thanks to you all helping out with this :)


All times are GMT -5. The time now is 09:35 AM.