LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Arch (http://www.linuxquestions.org/questions/arch-29/)
-   -   Logging out... But can't get back to GUI without rebooting (http://www.linuxquestions.org/questions/arch-29/logging-out-but-cant-get-back-to-gui-without-rebooting-899065/)

kasl33 08-23-2011 10:24 PM

Logging out... But can't get back to GUI without rebooting
 
I'm running Arch and have everything running perfectly (with the exception of my Dell V515W all-in-one printer and log out, log back in to the GUI.

What can I do so that in my Gnome session (I use fallback mode), when I log out, I can log back in without rebooting?

I have tried pkill x and many other things. What is the magic command (I am using slim as my login manager)?

Mr. Alex 08-24-2011 01:07 AM

Maybe
Code:

sudo /etc/rc.d/gdm start
?

kasl33 08-24-2011 12:34 PM

Well, it's actually slim that I'm using - not gdm. However, regardless, the problem lies within Xorg somewhere. Here are some details of the problem:

I log out of the GUI and, instead of bringing up SLIM again, it leaves me to login at the command prompt:

Code:

Fatal Error: no screens found

xinit: giving up
xinit: unable to connect to x server: Connection refused
xinit: Server Error

------------------

kris@localhost$ sudo rc.d restart slim
Stopping Simple Login Manager                [FAILED] (probably because it is already stopped
Starting Simple Login Mangaer                  [DONE]

------------------

startx then fails again (or sudo rc.d start slim as well) and I get the same errors as listed above.


dodgefan 08-24-2011 06:04 PM

have you tried going right to runlevel 5?

edit /etc/inittab and comment out the line for runlevel 3 and uncomment the line for runlevel 5

Code:

#id:3:initdefault:
id:5:initdefault:

and also uncomment the line to start Slim

Code:

x:5:respawn:/usr/bin/slim >& /dev/null

kasl33 08-24-2011 06:43 PM

Quote:

Originally Posted by dodgefan (Post 4452552)
have you tried going right to runlevel 5?

edit /etc/inittab and comment out the line for runlevel 3 and uncomment the line for runlevel 5

Code:

#id:3:initdefault:
id:5:initdefault:

and also uncomment the line to start Slim

Code:

x:5:respawn:/usr/bin/slim >& /dev/null

Yep. Tried those too. Just tried them again and had no luck. I typically ignore the /etc/inittab file during setup and just ad slim to the DAEMONS array in /etc/rc.conf. I wonder if this could be a bug in X?

dodgefan 08-24-2011 08:44 PM

and slim is the last item in the daemons list?

that is weird, i'll have to try that when i get home. im using xfce, but i do use slim. i'll load it from rc.conf and see if i can get the same result

dodgefan 08-25-2011 07:34 PM

no go, i loaded slim as a daemon with runlevel set at 3. slim loads fine, i can log into xfce and when i logout, it takes me to the slim login screen

kasl33 09-01-2011 12:05 PM

Sorry for the long delay. I went camping for the weekend in the mountains.

Anyway, I have the runlevel 3 option uncommented (and slim commented out below) in the /etc/inittab file. I also have slim listed as the last to load in the daemons array.

I wonder if it could be some kind of bug with video drivers or something. It's as if X doesn't properly shut down. Even if I run pkill x or other commands.

kasl33 09-06-2011 01:58 PM

I'm still stuck on this. Does anybody else have any good ideas?

berbae 09-07-2011 10:31 AM

Quote:

Originally Posted by kasl_33 (Post 4458943)
Anyway, I have the runlevel 3 option uncommented (and slim commented out below) in the /etc/inittab file. I also have slim listed as the last to load in the daemons array

If you speak of the daemons array in the /etc/rc.conf file, you cannot use together the inittab file and the rc.conf file to start slim at boot. You need to choose one or the other, but not both of them.

kasl33 09-07-2011 12:52 PM

That's not it either. I removed slim from rc.conf and only have runlevel 5 and slim uncommented in /etc/inittab

kasl33 09-17-2011 02:23 PM

Update: I believe this might be an error with the Nvidia drivers. I decided to play with Archbang the other day and had the exact same issue. Even now, with stock Arch on here and no login manager, it still happens. Runlevel 3 is the only thing not commented in the /etc/inittab file and startx is my command for starting x. When I logout, I always have to reboot before I can log back into a GUI environment.


All times are GMT -5. The time now is 07:56 PM.