LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices



Reply
 
Search this Thread
Old 10-29-2006, 09:55 AM   #1
bgbranko
LQ Newbie
 
Registered: Apr 2006
Distribution: Arch Linux
Posts: 23

Rep: Reputation: 15
Kaffeine not starting (KDE 3.5.5)


Hi,

I'm posting here because I'm still waiting to get registered with the main Arch forum at bbs.archlinux.org.

I've installed and run Arch before, so I'm not a complete noob. However, I'm quite new to Linux in general, so please bear with me. Anyway, I installed arch from 0.7.2 Gimmick CD. I installed base packages only as recommended by many users. Then I upgraded the base set using pacman and installed a host of packages from KDE to whatnot. Among other things, I installed Kaffeine.

I ran Kaffeine once, and it did work. But the next time I started it, it wouldn't even show errors in the konsole. What gives?

TIA

B
 
Old 10-30-2006, 04:04 AM   #2
muslim
LQ Newbie
 
Registered: Oct 2006
Distribution: arabian
Posts: 11

Rep: Reputation: 0
Had you tried killing any task which concern Kaffeine (e.g. by using Ksysguard) and then run it again?
 
Old 10-30-2006, 04:29 AM   #3
bgbranko
LQ Newbie
 
Registered: Apr 2006
Distribution: Arch Linux
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by muslim
Had you tried killing any task which concern Kaffeine (e.g. by using Ksysguard) and then run it again?
No, I've not killed anything... yet.

EDIT: It's always the same whether I reboot or log out or restart X... every time I log in as my main user, kaffeine won't start.

Here's what I've tried so far:

I've tried to start kaffeine as root. It works just fine. Then I tried to create another user and start kaffeine. That works, too, but the new user has no sound. FYI, I've inserted esd into my daemons list in rc.conf (I don't know if that's really necessary to have sound in Arch... I've set up the main user account to use esd via arts, and it works fine, so I didn't change this.) I also have ALSA configured using alsaconf. Sound is not an issue with the main user account.

I also tried to move all my configuration folders and files from /home/user to another location to see if kaffeine would work, and indeed it does. But the sound is gone if I do that. I suspect it has to do with how my KDE is configured, but I'm not sure.

EDIT: I've also added the user account to audio, video, optical, and storage groups, but that didn't help.

Also, switching to tty1 where X errors are shown, I can see lots of errors concerning kaffeine, something about bad mime type or something. I'd have to double check this once I'm home. Where is the log located, btw? I can perhaps copy & paste the errors.

B

Last edited by bgbranko; 10-30-2006 at 04:37 AM.
 
Old 11-25-2006, 07:13 PM   #4
hladky.jiri
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
Solution

Hi,

I saw the same problem after upgrading to kaffeine 0.8.2

Kaffeine was running for all other users.
For me, it was starting only with

Code:
kaffeine --nofork
The solutin was to execute this command:
Code:
dcop kaffeine MainApplication-Interface quit
After this, it has started to work as usual. Option --nofork is not needed anymore, I can start it again with
Code:
kaffeine
I hope that it helps!
Jiri
 
Old 11-26-2006, 05:50 AM   #5
bgbranko
LQ Newbie
 
Registered: Apr 2006
Distribution: Arch Linux
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by hladky.jiri
The solutin was to execute this command:
Code:
dcop kaffeine MainApplication-Interface quit
After this, it has started to work as usual. Option --nofork is not needed anymore, I can start it again with
Code:
kaffeine
I hope that it helps!
Jiri
The dcop thing doesn't work for me... However, "--nofork" does work. Thanks for the tip. What does it mean anyway?

Meanwhile, I've switched to good ol' xine-ui... never let me down.


EDIT:

I just killed Kaffeine using

Code:
killall kaffeine
and now it starts just okay. I got the idea from that dcop quit thing. Thanks for the inspiration.

Last edited by bgbranko; 11-26-2006 at 05:52 AM.
 
  


Reply

Tags
arch, kaffeine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Start Xine not Kaffeine in KDE? Napalm Llama Linux - Software 6 02-17-2006 03:13 PM
KDE 3.4 upgrade in FC2 - kaffeine 0.6 and amarok _UnPrEdictAbLe_ Fedora 0 05-14-2005 03:05 PM
Fedora core 3, KDE, aRts and Kaffeine problem. _UnPrEdictAbLe_ Linux - Software 1 01-07-2005 04:32 AM
Kaffeine in KDE 3.2 causes logout suttree Debian 4 06-04-2004 11:19 PM
starting kpppd w/ ximian or starting ximian w/ kde ergo_sum Linux - Newbie 8 12-02-2003 06:35 AM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration