LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 10-22-2010, 08:53 PM   #1
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
gdm-binary: /var/run/dbus/system_bus_socket: No such file or directory


Update: Now, I *CAN* get the installation to boot, but I can't get it to load past twm despite having a full desktop environment (GNOME), GDM, and even non-standard apps installed.

As for the error message that GDM is putting out, it's something like:

Code:
***(gdm-binary)***: /var/run/dbus/system_bus_socket: No such file or directory
I'm still trying to figure out how to hook dbus into the initrd.

Last edited by Kenny_Strawn; 10-24-2010 at 03:49 AM. Reason: Edited title
 
Old 10-22-2010, 09:04 PM   #2
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,057

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
needs to be sdb1 sdb2, etc right?
not /dev/sdb

change the fstab and grub boot line manually for /dev/sdb1 /, root=/dev/sdb1, etc

did you DD it to the drive?
 
Old 10-22-2010, 09:10 PM   #3
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
Yeah, my mistake, I did try that. It still caused the same problem.
 
Old 10-22-2010, 09:19 PM   #4
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
Also tried editing /etc/fstab. No change.
 
Old 10-22-2010, 09:30 PM   #5
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,057

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
how did you transfer it to the drive, unsquashfs'd it and then copied it?
does the drive have a sdb1?
whats the output of fdisk -l as root?
 
Old 10-22-2010, 09:45 PM   #6
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
I decided to 'unsquashfs' it directly to the drive, using
Code:
unsquashfs root-image.sqfs -fd /mnt
with the drive mounted in /mnt. Then, I installed the needed and wanted packages on the drive, installed GRUB, and updated GRUB. Yet, I've run into these roadblocks every time I tried to boot it!

Last edited by Kenny_Strawn; 10-22-2010 at 09:46 PM.
 
Old 10-22-2010, 09:47 PM   #7
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
And yes, it does have an sdb1; I specifically created it in GParted so that I could use GRUB on it.
 
Old 10-22-2010, 10:21 PM   #8
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
i forget the command, but you need to delay mounting root, which is your external drive, to allow archlinux time to discover it first. I used to use 6 seconds which was fine for my external.

here is the command you need to put on your kernel line in grub
rootdelay=6
change the 6 to however many seconds you feel is needed.

Last edited by sandman; 10-22-2010 at 10:26 PM. Reason: added command
 
Old 10-22-2010, 10:24 PM   #9
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
The default is 10 seconds, and the kernel still isn't finding it. How do you modify that value?
 
Old 10-22-2010, 10:33 PM   #10
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
you need to edit /boot/grub/menu.lst as root and look for your kernel line. here is an example with the rootdelay=6 added to it

kernel /vmlinuz26 root=/dev/sdb10 rootdelay=6 ro
 
Old 10-22-2010, 10:34 PM   #11
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
Actually, that's for legacy GRUB. I have GRUB 2.
 
Old 10-22-2010, 10:38 PM   #12
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
I decided to edit my /etc/default/grub and include "rootdelay=30" in the "GRUB_CMDLINE_LINUX" variable, then update GRUB. Hopefully, this will solve the problem. At 10 seconds, it still isn't working.
 
Old 10-22-2010, 10:39 PM   #13
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
you can still add kernel options in grub.cfg using grub 2
here is wiki page for grub 2
http://wiki.archlinux.org/index.php/GRUB2
 
Old 10-22-2010, 10:43 PM   #14
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Original Poster
Rep: Reputation: 54
Still, 30 seconds doesn't fly.

I wonder if it registers as a different device, say /dev/sda1, on the external device? I will try to see if that is the case.
 
Old 10-22-2010, 10:48 PM   #15
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
try labeling the drive and then boot by-label instead of by-uuid or by device. info here
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing "dev" section in Arch Mr. Alex Arch 7 12-05-2010 09:06 AM
"bad interpreter : no such file or directory" when configure "flex" acer_peri Linux - Software 10 11-10-2010 01:19 AM
How do you install thinks on Arch? What is arch for "emerge", "apt-get" etc? just a man Arch 8 02-04-2010 11:06 AM
C Drive "/dev/hda1" accidently used in dd command at "of=" switch M D Linux - Software 4 04-26-2007 08:56 AM
2.4 kernel w/ devfs "/dev/tty1-8: No such file or directory" hedpe Linux - Software 0 05-19-2006 05:37 PM


All times are GMT -5. The time now is 08:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration