LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2010, 04:19 PM   #1
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Rep: Reputation: 78
Full system upgrade killed my nvidia drivers


I did a full system update yesterday on my Arch system. After showing a successful update message, I turned off my system for the night. This morning when I turned the computer back on, my nvidia drivers no longer work. I was able to revert to the nouveau drivers without any problems, but I would like to have my 3d acceleration working again from the proprietary driver. The error message I'm getting is that xorg failed to initialize the nvidia driver. and that there is no display. I don't currently have access to my xorg.conf or my log files, but I will post as soon as I get a chance.

Short of having those files, any ideas?
 
Old 05-22-2010, 04:41 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Part of your upgrade may have updated the kernel version.
If you still have your old kernel in the boot menu, try booting up to it to see if that is the problem. Then (after rebooting into your new kernel again) I would re-run the nvidia installer so that it rebuilds the nvidia kernel driver. Part of the installer process also installs GL files that you will need for compositing as well.
 
Old 05-24-2010, 04:14 PM   #3
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Original Poster
Rep: Reputation: 78
Ok, sorry it took so long to get back here, jschwal, i do not have my old kernel, if it was even upgraded. I'm not sure what the kernel was when I had it working originally. It is 2.6.33-ARCH now. I have attached my log file.

Code:
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.33-ARCH i686 
Current Operating System: Linux Ziggy 2.6.33-ARCH #1 SMP PREEMPT Thu May 13 12:06:25 CEST 2010 i686
Kernel command line: root=/dev/disk/by-uuid/c41e6bc0-1b29-4496-994e-0814f752a2d5 ro
Build Date: 01 April 2010  05:35:33PM
 
Current version of pixman: 0.18.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May 24 21:09:09 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/100dpi:unscaled,
	/usr/share/fonts/75dpi:unscaled,
	/usr/share/fonts/TTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/misc,
	/usr/share/fonts/100dpi:unscaled,
	/usr/share/fonts/75dpi:unscaled,
	/usr/share/fonts/TTF,
	/usr/share/fonts/Type1
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x81e4c60
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 6.0
	X.Org XInput driver : 7.0
	X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:1:0:0) 10de:06e4:1043:82b2 nVidia Corporation G98 [GeForce 8400 GS] rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Server Extension
(II) NVIDIA GLX Module  195.36.15  Thu Mar 11 23:39:48 PST 2010
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
dlopen: libdrm.so.2: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/lib/xorg/modules/extensions/libdri.so
(II) UnloadModule: "dri"
(EE) Failed to load module "dri" (loader failed, 7)
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
dlopen: libdrm.so.2: cannot open shared object file: No such file or directory
(EE) Failed to load /usr/lib/xorg/modules/extensions/libdri2.so
(II) UnloadModule: "dri2"
(EE) Failed to load module "dri2" (loader failed, 7)
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  195.36.15  Thu Mar 11 22:01:49 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
	compiled for 1.7.6, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) May 24 21:09:09 NVIDIA(0): Enabling RENDER acceleration
(II) May 24 21:09:09 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) May 24 21:09:09 NVIDIA(0):     enabled.
(EE) May 24 21:09:09 NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0. 
(EE) May 24 21:09:09 NVIDIA(0):     Please check your system's kernel log for additional error
(EE) May 24 21:09:09 NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
(EE) May 24 21:09:09 NVIDIA(0):     README for additional information.
(EE) May 24 21:09:09 NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
This line: (EE) May 24 21:09:09 NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
caught my eye. Not sure how to fix it. All help is greatly appreciated
 
Old 06-07-2010, 02:22 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Take a look in /lib/modules/. You should have a directory that has your kernel version in the name.
On my Linux system, it looks like this:

ls -d /lib/modules/$(uname -r)
/lib/modules/2.6.31.12-0.2-desktop
find /lib/modules/$(uname -r)/ -iname "nvidia*"
/lib/modules/2.6.31.12-0.2-desktop/kernel/drivers/video/nvidia
/lib/modules/2.6.31.12-0.2-desktop/kernel/drivers/video/nvidia/nvidiafb.ko
/lib/modules/2.6.31.12-0.2-desktop/weak-updates/updates/nvidia.ko

I've also listed the nvidia kernel modules. It is the nvidia.ko module that I think you may be missing. Double check this on your system.
If you don't have it, there are two courses of action. You may have an nvidia package available from an arch repository for your new kernel, and can simply install that package. If not download the latest driver from nvidia for your card. I don't know if you have ever built a package before or if you have built a kernel. There may be some dependencies you will need to install.

This Arch wiki covers installing the propriety nvidia driver. You might also want to paste your xorg.conf file in case it needs to be modified.
If you do install the propriety nvidia driver, there are two programs, "nvidia-settings" and "nvidia-xconfig" that can help you set up your xorg.conf file. The nvidia-settings program is especially handy if you have special circumstances such as dual monitors.
 
Old 06-07-2010, 02:47 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
Quote:
I would like to have my 3d acceleration working again from the proprietary driver.
from the above posts it looks like you installed the nvidia.run driver AND NOT the driver from pacman

for the .run driver you NEED to reinstall it EVERY TIME there is an update to the
kernel,Xorg,X11 , and mesa ( that one is a maybe )
 
Old 06-07-2010, 05:36 PM   #6
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 648

Original Poster
Rep: Reputation: 78
I originally had the nvidia driver from pacman installed. After it quit working, I installed the nvidia.run file on the new kernel, and it also would not work. I'm not sure that this is a Arch only problem, the nvidia driver doesn't work on my Fedora 13 box either with the new kernel.
 
Old 06-07-2010, 08:30 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
WHAT nividia.run driver ? one of the 195 's ( i think was recalled -- it was bad)
but that was about 2 , 4 months ago


ALSO VERY VERY VERY IMPORTANT -- yes caps !!!!
going from the arch.xz or fedora rpm or debain .deb to the nvidia.run
you must first remove the old driver 100% FIRST
and visa versa if you go from the run to a distro specif from the package manager
the OLD ONE MUST BE REMOVED FIRST


so for arch ( this IS the recommended way )
use the one in pacman -- if at all possible ( i don't ,but that is me )

------------ instructions ------
1) remove the .run ( you NEED the .run still on your system - i put it on / )
Code:
su -
cd / 
sh *.run --uninstall
2) delete xorg.conf
3) reboot into text only ( this will be automatic seeing as x will not start )
4) login as root
5) pacman -S nvidia ( install the arch nvidia driver


now if you do decide to use the nvidia.run driver -- remember
for EVERY kernel,x11,xorg ,and mesa update it MUST be reinstalled AND ALL OF Mesa must also be reinstalled after you install the .run

nvidia's driver changes the system mesa.so AND .h files

Last edited by John VV; 06-07-2010 at 08:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce worked once, Nvidia linux drivers killed it, and now i can't fix it. conway.federico Linux - Hardware 8 10-16-2008 10:28 PM
apt-get dist-upgrade killed system android6011 Ubuntu 2 12-28-2006 03:25 AM
FC5 upgrade to one FC4 on multi-boot system killed the others PTrenholme Fedora 0 03-21-2006 10:15 PM
Slapt-get upgrade to current killed my system zwyrbla Slackware 15 01-27-2005 09:35 PM
nvidia 3d drivers killed xserver eggstain Linux - Software 4 01-24-2003 01:27 PM


All times are GMT -5. The time now is 01:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration