LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Amigo
User Name
Password
Amigo This forum is for the discussion of Amigo Linux.

Notices

Reply
 
Search this Thread
Old 09-28-2004, 05:53 AM   #1
datamin0r
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
Missing libs that fluxbox uses after installing slack 8.1 via guide


I installed slack 8.1 via the amigo/phoenix guide and everything went well, i configured X and was able to run WindowMaker with no problems.

I saw a few people that were running fluxbox on 8.1 and that is what I'd like to run on this setup so I grabbed the fluxbox-0.1.14-i386-1.tgz off of one of my slack 10 cd's and installed it using the pkgtool command.

It looks like everything went well, but when I run the startx command I get this error: error while loading shared libraries: libXft.so.2

Also, when I use the ldd fluxbox command I see that 3 files are not found... libXft.so.2, libfontconfig.so.1 and libstdc++.so.5

I've been working on this for most of the day on and off, I'm wondering if my mistake was using the package from the slack 10 cd and not installing from source... or if I just need to install a package or two that contain the missing files.

the reason I didn't just install from source is, I'm not sure with the minimal installation that I have the files required to do so.

BTW, my system is an IBM laptop 150mhz mmx w/ 2GB hd.

Any help or advice would be greatly appreciated, thanks alot.
 
Old 09-28-2004, 08:06 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,749

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Nothing from Slack 10 will run on Slackware 8.1 unless it says 'noarch' in the package name. fluxbox didn't come in Slackware 8.1 so you are stuck with blackbox or maybe there is a compile of fluxbox for slackware 8.1 on linuxpackages.net.
Those that are using fluxbox are probably using Amigo2.
I even made one for you! Didn't you see this on the download page?
http://amigolinux.org/download/others/amigo-II-flux.zip
As far as dependencies, the only thing fluxbox needs, other than the regular (correct version!) of glibc-so and X libs, is cxxlibs, since fluxbox is written in c++. These are included in Amigo.
 
Old 09-28-2004, 03:31 PM   #3
datamin0r
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Cool, I figured I'd just give it a shot...

I appreciate the quick comment, maybe I'll get amigo II up and running today.

thx!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
always missing some libs. txotxo Suse/Novell 3 10-03-2005 04:36 PM
Ultimate Slack Server Guide::Installing Apache2, PHP4, MySQL4, Webmin1.2, phpMyAdmin Eric45008 Slackware - Installation 9 04-25-2005 11:59 PM
Missing curl-libs compiling GRIP senorsnor Slackware 7 10-18-2004 10:54 PM
Can't install GTK because of missing XFree86-libs n00billy Red Hat 4 03-30-2004 10:31 AM
installing slack 8.1 and fluxbox N_A_J_M Slackware 2 02-04-2003 03:51 PM


All times are GMT -5. The time now is 02:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration