LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   AIX (http://www.linuxquestions.org/questions/aix-43/)
-   -   Trouble installing openssh4.1p1 on AIX5.1 (http://www.linuxquestions.org/questions/aix-43/trouble-installing-openssh4-1p1-on-aix5-1-a-424714/)

shweta pandey 03-14-2006 07:51 AM

Trouble installing openssh4.1p1 on AIX5.1
 
Hi I have an AIX5.1 m/c with ML04 and I wasnt able to install openssh4.1p1 on it. The prerequisites were as follows:
zlib-1.2.2-4
prngd-0.9.29-1
openssl-0.9.7g-1
While installing openssh4.1p1 through smitty it gives following errors:
sysck: 3001-022 The file
/.ssh/prng_seed
was not found.
sysck: 3001-017 Errors were detected validating the files
for package openssh.base.server.

0503-464 installp: The installation has FAILED for the "root" part
of the following filesets:
openssh.base.server 4.1.0.1

installp: Cleaning up software for:
openssh.base.server 4.1.0.1

I also observed if I manually create an empty file /.ssh/prng_seed the installation is successfull but then I dont see any entry in the /etc/services file for ssh and I am unable to start the sshd daemon.

critical_section 03-14-2006 12:45 PM

did you remove any existing version before you installed it?
Why don't you grab the source and build it to your liking?
I think 4.2.1 supports password changing upon login, where 4.1.0.1 does not. I requires the same prereqs that you name, and I've built it with no problem.
Actually if you have an FTP site I can drop the install/TAR file there for you to untar on your server.

Cheers,
Christoble

rahil_12inin 10-21-2006 07:51 PM

HI, trouble installing openssh
 
I was trin to install openssh, and having the same problem as shwetha.can u plz help me out . or can u plz forward me hte sourse code for openssh u have.
will really appriciate ur help

tcort 10-23-2006 06:49 AM

Quote:

Originally Posted by shweta pandey
Hi I have an AIX5.1 m/c with ML04 and I wasnt able to install openssh4.1p1 on it. The prerequisites were as follows:
zlib-1.2.2-4
prngd-0.9.29-1
openssl-0.9.7g-1

It is a good thing that it failed ;)

zlib 1.2.2 security advisories:
http://www.kb.cert.org/vuls/id/680620
http://www.kb.cert.org/vuls/id/238678

openssl security advisories:
http://www.openssl.org/news/secadv_20060905.txt

Whenever you install software which is that out of date and allows remote access, it is important to check if there are any security problems associated with running it. My suggestion would be to build those apps from source. If you need a compiler, IBM has binaries for GCC at the following URL:
http://www-03.ibm.com/servers/aix/pr.../download.html

tcort 10-23-2006 06:51 AM

Quote:

Originally Posted by rahil_12inin
I was trin to install openssh, and having the same problem as shwetha.can u plz help me out . or can u plz forward me hte sourse code for openssh u have.
will really appriciate ur help

http://www.zlib.net/
http://www.openssl.org/source/
ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/


All times are GMT -5. The time now is 10:45 PM.