LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices



Reply
 
Search this Thread
Old 05-19-2006, 07:01 AM   #1
AbrahamJose
Member
 
Registered: Feb 2006
Location: India
Posts: 165

Rep: Reputation: 30
Question Problem in sending mail


When I send mail to another aix node by

mail user1@host1

After the compeletion of the process, I get the error message

Can't create transcript file ./xfh32JMhl01671: Permission denied

It is observed that mail is not send

Can anybody help me?
 
Old 05-19-2006, 07:35 AM   #2
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
i am not sure but i think you need write access to that file its complaining about.
 
Old 05-22-2006, 09:22 PM   #3
AbrahamJose
Member
 
Registered: Feb 2006
Location: India
Posts: 165

Original Poster
Rep: Reputation: 30
Post permission

It is the /var/spool/mail direcory, that handles the mail

In some machines mail is working

In some other machines with the same permisiions, mail is not working.
 
Old 05-25-2006, 07:08 AM   #4
AbrahamJose
Member
 
Registered: Feb 2006
Location: India
Posts: 165

Original Poster
Rep: Reputation: 30
Post further

It is observed that AIX 4.3 has no such problem.
All the AIX 5.2 boxes have this problem.

Is it a bug with AIX 5.2?

Any suggestion?
 
Old 05-27-2006, 10:15 AM   #5
Michael AM
Member
 
Registered: May 2006
Distribution: AIX 5.3, AIX 6.1, AIX 7.1
Posts: 95

Rep: Reputation: 23
I would check that the directory /var/spool/ directories.

the mail directory is for the inboxes, mqueue is for processing mail

On my system (mail is working) I have the following permissions:

michael@x054:[/usr/include]ls -ld /var/spool/m*
drwxrwxr-x 2 bin mail 4096 May 25 17:32 /var/spool/mail
drwxrwx--- 2 root system 256 May 27 16:13 /var/spool/mqueue
 
Old 05-29-2006, 01:25 AM   #6
AbrahamJose
Member
 
Registered: Feb 2006
Location: India
Posts: 165

Original Poster
Rep: Reputation: 30
Post

Thank u Micheal

In my machines owner of mqueue directory was bin
I changed it to root
Now I can send mail to a user in the same host.
(mail user1)

But mail user1@host1
returns the mail
Can u send mail to another host in the NW as an ordinary user?
Any suggestion ?

Last edited by AbrahamJose; 05-29-2006 at 01:29 AM.
 
  


Reply

Tags
mail


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mail sending problem !!! hitesh_linux Linux - Networking 6 09-22-2004 11:01 PM
problem when sending mail adm1329 Linux - Software 3 03-18-2004 10:59 AM
sending mail outside problem dangerousjohnny Linux - Newbie 2 03-02-2004 03:11 PM
Mail sending problem Bernhard Linux - Software 6 06-03-2003 02:34 AM
problem with sending mail DreamerNS Linux - Software 0 03-30-2003 12:30 PM


All times are GMT -5. The time now is 07:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration