LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices



Reply
 
Search this Thread
Old 03-01-2013, 09:37 AM   #1
psbeekeeper
LQ Newbie
 
Registered: Mar 2013
Posts: 1

Rep: Reputation: Disabled
I broken RPM :(


So I was installing some RPM packages in AIX 6.1 and not sure how it broke, but now RPM does not work. I get this message when trying to use it:

{root@nim:/opt/freeware/lib} 09:17:19 > rpm
exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors:
0509-022 Cannot load module /opt/freeware/lib/libintl.a(libintl.so.1).
0509-150 Dependent module /opt/freeware/lib/libiconv.a(shr4.o) could not be loaded.
0509-152 Member shr4.o is not found in archive
0509-022 Cannot load module rpm.
0509-150 Dependent module /opt/freeware/lib/libintl.a(libintl.so.1) could not be loaded.
0509-022 Cannot load module .
{root@nim:/opt/freeware/lib} 09:36:04 >




Can I just pull files from another AIX 6.1 server and put it on my broken one to resolve the issue?
 
Old 03-01-2013, 02:25 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 13,535

Rep: Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807
First why were you using "rpm" and not "yum " ?
yum resolves the dependencies .

this is what RHEL 6 or RHEL 5 on the ibm server

i would contact RedHat tech support
you are paying a lot of cash for the server license

or
is some other OS like CentOS installed on the ibm server
 
Old 03-03-2013, 06:24 PM   #3
DukeSSD
Member
 
Registered: Sep 2007
Posts: 88

Rep: Reputation: 20
AIX This forum is for the discussion of IBM AIX.

And, yes.

Find a similar level system and copy them over but check for links and stuff on the working system to see what is required.

Last edited by DukeSSD; 03-03-2013 at 06:29 PM.
 
Old 03-12-2013, 07:38 AM   #4
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 1,949

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
Guess it means your /opt/freeware/lib/libiconv.a file got deleted/corrupted... And you cannot reinstall it without rpm, obviously.
Still, you can download it http://www.bullfreeware.com/download...aix6.1.ppc.rpm, extract the content (in a linux machine, with midnight commander), then manually copy the libraries to their place.

PS: Or, as you have suggested, copy from another AIX computer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
broken gcc++ and rpm Zuess Linux - Software 0 02-07-2006 09:10 PM
RPM broken after install bofallon Linux - Newbie 0 04-22-2004 05:47 PM
Why is rpm broken? mansonmuni Linux - Software 3 12-26-2003 05:55 PM
rpm is broken wlfdgcrkz Linux - Software 4 05-13-2003 04:54 AM
rpm broken for root? ubien Linux - General 1 01-23-2003 02:07 AM


All times are GMT -5. The time now is 09:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration