LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices

Reply
 
Search this Thread
Old 01-13-2013, 10:42 PM   #1
gaugeta
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Rep: Reputation: Disabled
GIT issue in AIX 6.1


Hello,

I recently installed GIT 1.8.1 on my AIX 6.1 machine and am facing a few issues with it.

Now if I login as root and issue git commands like git --version I get the response as shown :
Code:

Code:
git version 1.8.1

And I have tried creating repositories as root too and it works fine.

Now If I login as just a normal user and if I issue the version command : git --version I am getting the response as :

Code:
genuser:stud:/students/admin> git --version
exec(): 0509-036 Cannot load program git because of the following errors:
        0509-150   Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
        0509-152   Member libiconv.so.2 is not found in archive

Now how come its working with root user and not working with normal user.

But If I issue man git command in normal user I'm getting the manual for git but the rest of the commands give the above error.

BTW the file libiconv.so.2 is not present in /usr/lib directory but it still works in root user but not in normal user.

How can I fix this.
 
Old 01-14-2013, 03:38 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,203

Rep: Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472Reputation: 2472
Quote:
Originally Posted by gaugeta View Post
Hello,
I recently installed GIT 1.8.1 on my AIX 6.1 machine and am facing a few issues with it. Now if I login as root and issue git commands like git --version I get the response as shown :
Code:
git version 1.8.1
And I have tried creating repositories as root too and it works fine. Now If I login as just a normal user and if I issue the version command : git --version I am getting the response as :
Code:
genuser:stud:/students/admin> git --version
exec(): 0509-036 Cannot load program git because of the following errors:
        0509-150   Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
        0509-152   Member libiconv.so.2 is not found in archive
Now how come its working with root user and not working with normal user. But If I issue man git command in normal user I'm getting the manual for git but the rest of the commands give the above error.

BTW the file libiconv.so.2 is not present in /usr/lib directory but it still works in root user but not in normal user.
How can I fix this.
Wherever the libiconv.a file is, your 'normal' user doesn't have permissions to read it, so you get the error. Root can read anything, so check the permissions on that file/directory, and modify them to allow 'normal' users to be able to read-only.

The man pages are just informational texts, and they're in a different directory, and opened with the man program. One doesn't have anything to do with the other.
 
Old 01-15-2013, 01:33 AM   #3
gaugeta
LQ Newbie
 
Registered: Jan 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
@TB0ne:Thanks for the reply.
Actually there was an issue with the LIBPATH variable which was solved after re-setting it.
 
  


Reply

Tags
aix, git


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't install Git repo (I don't git git ) Nemus Linux - Software 3 05-20-2011 02:09 PM
Tortoise GIT Issue? your_shadow03 Linux - Newbie 0 02-24-2009 01:21 AM
Issue during GIT? your_shadow03 Linux - Newbie 0 02-02-2009 01:17 AM
inconsistency issue of git-clone ***/git/mesa/drm with the existing kernel source centguy Linux - Desktop 2 10-08-2008 10:36 PM
Issue while installing GIT on Linux ?? ajeetraina Linux - Server 3 08-31-2007 12:24 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration