LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices



Reply
 
Search this Thread
Old 09-09-2007, 04:18 PM   #1
Vilius
Member
 
Registered: Jan 2006
Location: Lithuania
Distribution: CentOS, Debian
Posts: 185

Rep: Reputation: 15
Force delete key to work in aix ksh ?


I'm using AIX console over putty.
I'm not very happy with default ksh command editing capabilities so I forced insert mode, arrow keys and command history by issuing:

set -o emacs
alias __D=`echo "\002"`
alias __C=`echo "\006"`

in emacs mode history works using ctrl+p, so only thing missing is del key-
How to force del key to work as it should ?

thanks
Vilius
 
Old 09-09-2007, 06:26 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Have you tried
Code:
stty erase ^?
or
Code:
stty erase ^H
Dave
 
Old 09-10-2007, 07:13 AM   #3
Vilius
Member
 
Registered: Jan 2006
Location: Lithuania
Distribution: CentOS, Debian
Posts: 185

Original Poster
Rep: Reputation: 15
neither of them works, just prints out ~ symbol.
 
Old 09-24-2007, 04:35 PM   #4
Rooster
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
Try "stty erase ^?"

BUT!!

To get the ^? part, you need to actually press your backspace key.

So literally type "stty erase <backspace>" and it will slap in the ^?
Then just press enter and you will have backspace.

unfortunately this does not appear to work in .profile startup. I know, annoying but I have already developed the habit of typing "stty erase <backspace>" when I first login to an AIX box via putty.

The other option is to use Exceed, which sets it all up nice and neat for you from the get-go.

-The Rooster
 
Old 09-25-2007, 05:45 PM   #5
DukeSSD
Member
 
Registered: Sep 2007
Posts: 88

Rep: Reputation: 20
Have you played with the PuTTY "configuration > keyboard" settings?

I don't use emacs but have found the delete key does not work in AIX, nor does the backspace until you change the setting from control-? to control-H.

Once you get used to using backspace instead of delete all is well.

Please let me / us know your results.
 
Old 10-15-2007, 01:47 PM   #6
Vilius
Member
 
Registered: Jan 2006
Location: Lithuania
Distribution: CentOS, Debian
Posts: 185

Original Poster
Rep: Reputation: 15
thanks guys, but my problem was to get delete key working, not backspace - I managed backspace to work using putty keyboard settings as DukeSSD mentioned. I can live with that(backspace) but I wanted all the keys to work 'properly'.
 
Old 04-29-2011, 10:53 AM   #7
vchalam777
LQ Newbie
 
Registered: Apr 2011
Posts: 1

Rep: Reputation: 0
Cool delete char

Not sure if the order in your .profile matters

Change the order from
stty erase ^?
stty erase ^h

to

stty erase ^h

stty erase ^?
 
Old 04-30-2011, 08:46 PM   #8
DukeSSD
Member
 
Registered: Sep 2007
Posts: 88

Rep: Reputation: 20
As far as I have ever known or found on AIX, and I only use ksh and the vi editor, the Del key simply does not work and cannot be made to work.

HTH but please let us know if you find a way.
 
Old 05-02-2011, 06:59 PM   #9
DukeSSD
Member
 
Registered: Sep 2007
Posts: 88

Rep: Reputation: 20
OK, just fired up my old 5.3 test box and the CDE, tried with dtterm and xterm on the native keyboard and console.

The Del key produces some strange results both on the ksh command line and in vi but all seem to result in a beep from the system and in the session none relate to deleting the character at the cursor, so as mentioned above, I don't think AIX supports the Del key in any obvious or known format.

HTH
 
Old 05-03-2011, 12:15 PM   #10
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
I've never used the delete key in all my years using AIX. Using vi mode in the shell, you just don't need it.

I did notice while trying to use it that it did produce odd results as DukeSSD suggested. For me it changed the case on the character it was on or made the entire current word uppercase.
 
Old 05-11-2011, 10:36 AM   #11
trbennett48
LQ Newbie
 
Registered: Apr 2011
Posts: 23

Rep: Reputation: 3
I have no problem using my delete-key.

In the PUTTY Terminal-Keyboard configuration:
- In the "Backspace Key" section, I selected "Control-H"
- In the "Home and End Keys" section, I selected "Standard"
- In the "Function Keys & Keypad" section, I selected "Xterm R6"

HTH,
-tony
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Delete key doesn't work on Gnome terminal in RedHat simbamford Linux - Newbie 2 11-26-2006 03:23 AM
Smart Key Signature ERRORS! How do I delete this bad key from my computer? Balarabay1 Linux - Software 4 09-27-2006 12:01 PM
please help to make delete key work thtr2k Solaris / OpenSolaris 14 03-30-2006 09:37 AM
Case Statement With Aix Ksh Scripting ']['HeBroken AIX 2 02-09-2005 01:44 PM
The program Screen, "delete" key doesn't work TroelsSmit Linux - Newbie 0 10-13-2004 08:55 AM


All times are GMT -5. The time now is 12:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration