LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   AIX (http://www.linuxquestions.org/questions/aix-43/)
-   -   AIX 5.3a won't authenticate my users from a Linux-based NIS server (http://www.linuxquestions.org/questions/aix-43/aix-5-3a-wont-authenticate-my-users-from-a-linux-based-nis-server-4175437467/)

Batmensch 11-16-2012 01:29 PM

AIX 5.3a won't authenticate my users from a Linux-based NIS server
 
We have an AIX 5.3a installation running on our AS/400. Our NIS servers is a Linux CentOS 6.x server. The AIX seems to be reading the NIS maps properly, ypcat on the password file works fine. However, the machine will not allow NIS users to log in. When we try, we get log messages like this:

Nov 16 08:55:33 alaix53a auth|security:info sshd[323708]: Failed password for testman from 172.25.13.17 port 42466 ssh2
Nov 16 08:55:33 alaix53a auth|security:info syslog: ssh: failed login attempt for testman from willow.hq.aldon.com

Not very helpful.

An lsuser of the above reveals the following (in part):Testman
login=true
su=true
rlogin=true
daemon=true
admin=false
sugroups=ALL
admgroups=
tpath=nosak
ttys=ALL
expires=0
auth1=SYSTEM
auth2=NONE
umask=22
registry=NIS
SYSTEM=compat

This user is only in NIS, it has not been set up locally, but it seems to have the proper permissions to log in. It does have a home directory available, and simply su'ing to the user works fine.

any ideas?

Batmensch 11-16-2012 01:44 PM

it's because we're using shadow; can we get AIX to use it?
 
OK, the problem seems to be that the passwords are in a shadow file and not in the NIS passwd file. Is there a way to get AIX to use the shadow file?


All times are GMT -5. The time now is 05:19 AM.