LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 02-03-2004, 01:36 PM   #1
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
xkb layout changing


Today I installed FreeBSD and the instalation went without any problems. The problem occured when I started X. I configured my X server to use bulgarian keyboard layout, and to switch to us by pressing CTRL+SHIFT. But now I can't swithc to us. I have some expirience with FreeBSD 5.0 and a lot of linux distros and it's the first time I'meeting problem like that. I added to the Gnome panel the Keyboard layout switcher and it works, but I can't switch with the keyboard - I have to point it with mouse. I don't like that kind of operating. Any ideas?
 
Old 02-03-2004, 02:13 PM   #2
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: Ubuntu, FreeBSD, NetBSD
Posts: 1,449

Rep: Reputation: 47
Option "XkbOptions" "grp:ctrl_shift_toggle,lv3:win_switch"

Or something like this... I don't use it myself. But you need to edit the options to allow the switch from the keyboard. xf86config should allow you to define this without having to guess exactly what options you need.

EDIT: That line should be in /etc/X11/XF86Config... but unless you know what you are doing you want to use the utility. Remember to restart X for it to take effect.

Last edited by frob23; 02-03-2004 at 02:15 PM.
 
Old 02-03-2004, 02:31 PM   #3
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Original Poster
Rep: Reputation: 31
actually I've done this.
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "bg"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
It always has worked this way, but now there is something wrong. Could it be bug or something?
 
Old 02-03-2004, 03:12 PM   #4
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: Ubuntu, FreeBSD, NetBSD
Posts: 1,449

Rep: Reputation: 47
I really don't know. Like I said... I don't use this feature and don't have it configured. I am pretty sure that Gnome isn't catching the keystroke so I haven't got a clue. If no one else on this board can venture a guess I would suggest writing the freebsd-questions list about it. Someone there will know about it and possibly will have a fix for it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the keyboard Layout from UK to US (Debian) critical Linux - Hardware 7 02-16-2005 03:35 PM
Changing keyboard layout SAC82 Linux - Software 5 10-18-2004 01:39 AM
Xkb problem when changing options Rajahuroman Linux - Software 0 05-27-2004 12:26 PM
changing desktop layout for all users of one system k4zau Linux - Software 0 09-06-2003 01:43 PM
Changing keyboard layout? Eits0 Linux - General 2 08-13-2002 06:57 PM


All times are GMT -5. The time now is 10:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration