LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   xkb layout changing (http://www.linuxquestions.org/questions/%2Absd-17/xkb-layout-changing-141856/)

Ipolit 02-03-2004 02:36 PM

xkb layout changing
 
Today I installed FreeBSD and the instalation went without any problems. The problem occured when I started X. I configured my X server to use bulgarian keyboard layout, and to switch to us by pressing CTRL+SHIFT. But now I can't swithc to us. I have some expirience with FreeBSD 5.0 and a lot of linux distros and it's the first time I'meeting problem like that. I added to the Gnome panel the Keyboard layout switcher and it works, but I can't switch with the keyboard - I have to point it with mouse. I don't like that kind of operating. Any ideas?

frob23 02-03-2004 03:13 PM

Option "XkbOptions" "grp:ctrl_shift_toggle,lv3:win_switch"

Or something like this... I don't use it myself. But you need to edit the options to allow the switch from the keyboard. xf86config should allow you to define this without having to guess exactly what options you need.

EDIT: That line should be in /etc/X11/XF86Config... but unless you know what you are doing you want to use the utility. Remember to restart X for it to take effect.

Ipolit 02-03-2004 03:31 PM

actually I've done this.
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "bg"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
It always has worked this way, but now there is something wrong. Could it be bug or something?

frob23 02-03-2004 04:12 PM

I really don't know. Like I said... I don't use this feature and don't have it configured. I am pretty sure that Gnome isn't catching the keystroke so I haven't got a clue. If no one else on this board can venture a guess I would suggest writing the freebsd-questions list about it. Someone there will know about it and possibly will have a fix for it.


All times are GMT -5. The time now is 05:07 PM.