LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 12-11-2011, 08:27 PM   #1
ljdelight
LQ Newbie
 
Registered: Dec 2011
Location: Kansas, USA
Distribution: FreeBSD
Posts: 3

Rep: Reputation: Disabled
uShare 1.1a config issues: failed to start / not streaming on FreeBSD 8.2


Hello,

I encountered a couple of problems with the uShare 1.1a port on FreeBSD 8.2. I tried locating the problem, but the source had some patch file and I got confused.

What do people usually do to fix this...? Email someone? Fix it themselves? Use mediatomb instead? btw I don't know the first thing about cvs.

Error 1:
Server does not stream to Xbox360/PS3 when:
(1) 'Enable DLNA' is set in port config and
(2) /usr/local/etc/ushare.conf has
Code:
USHARE_DLNA_ENABLE=yes
.
After removing that line from ushare.conf, streaming works to both Xbox360 and PS3. Note that /var/log/messages shows that uShare started successfully.

For reference here's my /usr/local/etc/ushare.conf
Code:
USHARE_NAME=uShare
USHARE_IFACE=re0
USHARE_DIR=/disk2/shared
USHARE_ENABLE_WEB=no
USHARE_ENABLE_TELNET=no
USHARE_ENABLE_XBOX=yes
#USHARE_ENABLE_DLNA=yes # uncomment to break
#EOF
Error 2:
uShare fails to start at boot. Calling
Code:
/usr/local/etc/rc.d/ushare start
works perfectly without error.
At first, I wanted to blame bad REQUIREs in /usr/local/etc/rc.d/ushare but couldn't hack it to work. Then I tried adding synchronous_dhclient="YES" to /etc/rc.conf; uShare works with that!

Here's a piece of /var/log/messages
Quote:
Dec 11 20:05:47 espresso uShare[811]: Interface re0 is up.
Dec 11 20:05:47 espresso root: /etc/rc: WARNING: failed to start ushare
Dec 11 20:05:49 espresso kernel: re0: link state changed to UP
Dec 11 20:05:49 espresso dhclient: New IP Address (re0): 192.168.1.145
 
  


Reply

Tags
config, failed, streaming, ushare


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Audio Streaming Issues SeRi@lDiE Slackware 10 11-07-2011 09:58 PM
[SOLVED] Chrome and Streaming Video Issues | Help! :) subtracted Linux - Software 2 07-09-2010 04:13 AM
red5 streaming server installation on debian squeeze failed. tkmsr Linux - Software 0 04-28-2010 06:26 AM
mysql failed to start. reinstall failed either!!! gavin2u Linux - Server 10 11-13-2008 10:07 PM
Sendmail - Config for IP Block's & Config Issues Thom_Redhat Linux - Software 1 04-07-2006 01:29 PM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration