LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Strange Cups Performance (http://www.linuxquestions.org/questions/%2Absd-17/strange-cups-performance-285838/)

jtshaw 02-03-2005 01:26 PM

Strange Cups Performance
 
So earlier this week I brought up a new machine with FreeBSD 5.3-RELEASE. This isn't my first time using FreeBSD but I have to say I'm not nearly as familure with it as I am Linux.

Anyway, I decided to move my IPP Printer Server (aka cups server) to the FreeBSD box. I used ports to install cups-1.1.23.0. Configuration went just fine.

What I can't figure out is why cups is taking so long to print anything. It does work, the documents do get printed out correctly. However, it is taking forever for it to happen. The printer comes to life almost immediatly whether I'm printing directly from the FreeBSD box or over the network via IPP. However, it seams to only print about 1 line per second as appose to the usual 6-10 ppm.

Anyway have any ideas?

Just to give you an idea of the full setup, I'm using pmn2ppa-1.12 with a Deskjet 720C and the foomatic script stuff to interface the two.


List of all print related ports packages I've installed:
cups-1.1.23.0
cups-base-1.1.23.0_3
cups-lpr-1.1.23.0
cups-pstoraster-7.07_3
foomatic-db-20040107_2
foomatic-db-engine-3.0.2,1
foomatic-filters-3.0.2_4
ghostsccript-gnu-7.07_12
enscript-letter-1.6.4
pmn2ppa-1.12

Also, if it helps anyone:

dmesg Parallel I/O Startup
Code:

ppc0: <Standard parallel printer port> port 0x378-0x37b irq 7 on acpi0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
ppbus0: IEEE1284 device found /NIBBLE/ECP
Probing for PnP devices on ppbus0:
ppbus0: <HEWLETT-PACKARD DESKJET 720C> SCP,VLINK
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0

interesting dmesg message
Code:

stray irq7
Interrupt storm detected on "irq7: lpt0"; throttling interrupt source
stray irq7


jtshaw 02-03-2005 01:57 PM

Ok.... I figured out a way to fix the problem. Apparently the default setting for hw.intr_storm_threshold is 500 which is way to low for printing. Setting it up to around 20,000 does the trick:)


All times are GMT -5. The time now is 07:39 PM.