LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Passing args to port / make and apache (http://www.linuxquestions.org/questions/%2Absd-17/passing-args-to-port-make-and-apache-665572/)

rob0t 08-26-2008 01:46 PM

Passing args to port / make and apache
 
Hello, I'm a newbie to FreeBSD, just decided to try it out yesterday (Veteran linux user though) and I'm loving it. I'm using FreeBSD 7.0-RELEASE. It literally installed a base system in minutes (while Gentoo would take hours and sometimes even fail) and successfully built a kernel, all in one day.

I am now trying to install Apache-2.2 using ports. Just as it was working on the dependencies it gave me this error:

Code:

===>  apache-2.2.6_2 depends on executable: python - found
===>  apache-2.2.6_2 depends on file: /usr/local/bin/perl5.8.8 - found
===>  apache-2.2.6_2 depends on file: /usr/local/bin/autoconf-2.61 - found
===>  apache-2.2.6_2 depends on file: /usr/local/bin/libtool - found
===>  apache-2.2.6_2 depends on shared library: expat.6 - found
===>  apache-2.2.6_2 depends on shared library: ldap-2.3.2 - not found
===>    Verifying install for ldap-2.3.2 in /usr/ports/net/openldap23-client
===>  Building for openldap-client-2.3.41
Making all in /usr/ports/net/openldap23-client/work/openldap-2.3.41
  Entering subdirectory include

  Entering subdirectory libraries
Making all in /usr/ports/net/openldap23-client/work/openldap-2.3.41/libraries
  Entering subdirectory liblutil

  Entering subdirectory liblber

  Entering subdirectory liblunicode

  Entering subdirectory libldap
/bin/sh /usr/local/bin/libtool  --mode=compile  cc -O2 -fno-strict-aliasing -pipe -I../../include -I../../include  -I/usr/loca$
 cc -O2 -fno-strict-aliasing -pipe -I../../include -I../../include -I/usr/local/include -DLDAP_LIBRARY -c options.c  -fPIC -DPI$
*** Error code 1

Stop in /usr/ports/net/openldap23-client/work/openldap-2.3.41/libraries/libldap.
*** Error code 1

Stop in /usr/ports/net/openldap23-client/work/openldap-2.3.41/libraries.
*** Error code 1

Stop in /usr/ports/net/openldap23-client/work/openldap-2.3.41.
*** Error code 1

Stop in /usr/ports/net/openldap23-client.
*** Error code 1

Stop in /usr/ports/www/apache22.
*** Error code 1

Stop in /usr/ports/www/apache22.

options.c:39: error: `LDAP_VENDOR_VERSION` undeclared here (not in a function)
options.c: In function `ldap_get_option`
optins.c:156: warning: assignment makes integer from pointer without a cast

Sadly Google gives me nothing :(

Now, it looks like there is a problem with Openldap-2.3.41-client. I tried installing it separately and it gave me this problem as well.

So I decided to go up a version and successfully installed Openldap-2.4.11-client separately. But Apache-2.2 will not for some reason see it and still continues to compile 2.3.41 client.

Now my question is, is there a way to force Apache port to skip 2.3 and use the 2.4 version of Openldap client? I tried looking through the Makefile files, but I could not find anything on forcing a higher version. Is there a way to pass an argument to the make command or force Makefile of Apache-2.2 to use the version that is currently installed (or use a higher version instead of 2.3)?



Thanks,


rob0t


PS: (So far, I used rmconfig and rebuilt the config without the Openldap support, but in the future I would like to use it.)

anomie 08-26-2008 03:12 PM

How did you "go up a version" for openldap? Did you do so by updating your ports tree and then you installed it from ports? (If not, you'll want to do that as the appropriate fix. See my sig for a link to the handbook.)

Alternatively, if you don't require mod_ldap (at least I think that's why it is trying to install openldap) you could use:
# cd /usr/ports/www/apache22 && make config

Disable LDAP support from there.

rob0t 08-26-2008 04:09 PM

Quote:

Originally Posted by anomie (Post 3260615)
How did you "go up a version" for openldap? Did you do so by updating your ports tree and then you installed it from ports? (If not, you'll want to do that as the appropriate fix. See my sig for a link to the handbook.)

Alternatively, if you don't require mod_ldap (at least I think that's why it is trying to install openldap) you could use:
# cd /usr/ports/www/apache22 && make config

Disable LDAP support from there.

I went up a version by going back to a parent directory (/usr/ports/..) and then going to openldap24-client. I noted that there was a 2.4.11 version somewhere online and thought i might find one in ports.

I will give updating the ports a try. If that doesn't work, I'll just remove the mod_ldap support.


Thanks,


rob0t

anomie 08-27-2008 09:46 AM

I see you've posted an identical thread on daemonforums here. Adding this URL reference as closure so that someone else reading the thread can make sense of it.

rob0t 08-27-2008 10:34 AM

Ah yes. I was trying to get more input and to see if anybody else had something similar.

Basically, upgrading the port collection fixes the compile.


All times are GMT -5. The time now is 07:46 AM.