LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 05-30-2005, 04:32 AM   #1
b:z
Member
 
Registered: Mar 2005
Posts: 146

Rep: Reputation: 15
openBSD - mysqld get error server version - please help me


my database is running on Redhat AS 4.0 with version MySQL 4.1.7 release 4.RHEL4.1. I have backuped my database used mysqldump into "databk.sql".
Then, i have install MySQL "mysql-server-4.0" version on my openBSD 3.6 system. I also try setup PHP forum when completed install mysql and PHP. Everything is ok.
However, when i try to restore the "databk.sql" to new database on openBSD 3.6, i have got the error message:
Quote:
ERROR 1064 at line 20: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 COMMENT='AB Users Infos'' at line 23
Is that wrong version of mysql? Am i right? Please help me solve the problem. In case i have to reinstall mysql to higher version, where can i find the package MySQL4.1 for my openBSD system ".tgz".
Thank you very much.
 
Old 05-30-2005, 10:09 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,118

Rep: Reputation: 315Reputation: 315Reputation: 315Reputation: 315
MySQL 4.1 includes several features not in previous versions, one of which is different character set support, hence your error message. You'll either need to edit your dump file to remove references to different charsets or upgrade to 4.1. You might check www.openbsd.org for a MySQL 4.1 package, but there may not be one. If not, go to www.mysql.com, download the source, and compile it yourself.
 
Old 05-31-2005, 04:01 AM   #3
b:z
Member
 
Registered: Mar 2005
Posts: 146

Original Poster
Rep: Reputation: 15
Quote:
-- MySQL dump 10.8
--
-- Host: localhost Database: dtbase
-- ------------------------------------------------------
-- Server version 4.1.7

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE="NO_AUTO_VALUE_ON_ZERO" */;

--
-- Table structure for table `abc_access`
--

DROP TABLE IF EXISTS `abc_access`;
CREATE TABLE `abc_access` (
`id` smallint(5) unsigned NOT NULL auto_increment,
`name` varchar(40) NOT NULL default '',
`login` varchar(20) NOT NULL default '',
`tester` tinyint(3) unsigned NOT NULL default '0',
`dev` tinyint(3) unsigned NOT NULL default '0',
`man` tinyint(3) unsigned NOT NULL default '0',
`security` smallint(5) unsigned NOT NULL default '0',
`password` varchar(32) NOT NULL default '',
`tz` time NOT NULL default '00:00:00',
`email` varchar(40) NOT NULL default '',
`spam` text,
`creation_date` datetime NOT NULL default '0000-00-00 00:00:00',
`updated_date` datetime default NULL,
`updated_by` varchar(40) default NULL,
`note` text,
`options` int(11) default NULL,
`active` tinyint(4) NOT NULL default '1',
`hqflag` tinyint(1) unsigned NOT NULL default '0',
`usermask` int(11) NOT NULL default '1',
PRIMARY KEY (`id`),
KEY `ID` (`id`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 COMMENT='ABC Users Infos';

--
-- Dumping data for table `abc_access`
--
This is the part include the error which i have got the error message when try restore database. Error here:
Quote:
foo# /usr/local/bin/mysql -u root -pdtpasswd lqd < lqd30-05-2005.sql
ERROR 1064 at line 20: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 COMMENT='ABC Users Infos'' at line 23
Where can i edit on that my backup mysql file: "lqd30-05-2005.sql"? Please show me your suggestion.
Thank you very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysqld port error darkenigmaa Linux - Software 1 09-19-2005 04:29 PM
Mysqld error jjwl89 Linux - Software 2 04-21-2005 04:48 PM
starting mysqld + OpenBSD Gsee *BSD 0 02-01-2005 05:36 AM
IPP to PrintServer: server-error-version-not-supported curtwilliams Linux - Networking 1 05-08-2004 07:13 AM
OpenBSD Mozilla version llama_meme *BSD 2 10-02-2002 11:25 AM


All times are GMT -5. The time now is 03:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration