LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 09-03-2012, 09:32 PM   #1
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Rep: Reputation: 0
Talking OpenBSD 5.1 installing kde from a cd-R disc no go...?


I typed: # mkdir -p /cdrom
# mount /dev/cd0a /cdrom
and I got this in blue (FSD does not lie within the partition!)
mount_udf: mount: Invalid argument

So, what is my next step from here....any ideas anyone?
 
Old 09-04-2012, 12:32 PM   #2
ocicat
Member
 
Registered: May 2007
Posts: 208

Rep: Reputation: 48
Quote:
Originally Posted by Tkbp4him@insightbb.c View Post
So, what is my next step from here....any ideas anyone?
Read the mount(8) manpage. You will find an example of mounting a CD-ROM in the examples section.
 
Old 09-04-2012, 09:38 PM   #3
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Talking OpenBSD 5.1 installing kde from a cd-r cont...

Ok, looked at man page mount (8) examples and typed: #mount -t cd9660 -r /dev/cd0a /mnt/cdrom and got this: mount_cd9660: /dev/cd0a on /mnt/cdrom: No such file or directory ? what now?
 
Old 09-04-2012, 09:42 PM   #4
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
deleted.

Last edited by vharishankar; 11-02-2012 at 12:23 PM.
 
Old 09-05-2012, 07:04 PM   #5
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Talking Open BSD 5.1 cont....

Hey, I typed: mount -t cd9660 -r /dev/cd0a/cdrom and I got the usage: mount [-Aadfruvw] [-t type]
mount [-dfrsuvw] special : node
mount [-dfruvw] [-o options] [-t type] special node
?? So....now what ya think?
 
Old 09-05-2012, 07:34 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886
I think that you missed a space between cd0a and /cdrom.
 
Old 09-06-2012, 05:57 PM   #7
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Talking cont. of Open BSD 5.1 kde from cd-r disc

Ok, I tried the: # mount -t_cd9660 -r /dev/cd0a /cdrom (with a added space thanks, and with the underline before the cd9660 and without it ) and I got : mount : no mount helper program found for _cd9660 : No such file or directory and before that I got same but: Invalid argument.

Also tried: # mount -a -t nonfs, mfs and got: the usage statement for mount?

Did some googlin about my finds and found that maybe I need to check out my dmesg output for my device and find out what fdisk reports on the device and then check the output of disklabel for the device. And maybe # fdisk -l /dev/sd1i (example).

Anyway that's where I'm at now...Thanks so far for the idea's, at least we are trying something....
 
Old 09-07-2012, 11:32 AM   #8
Reuti
Senior Member
 
Registered: Dec 2004
Location: Marburg, Germany
Distribution: openSUSE 15.2
Posts: 1,339

Rep: Reputation: 260Reputation: 260Reputation: 260
How was the CD-R created? Is it known to contain an ISO9660 image at all when you check it on another system?

Last edited by Reuti; 09-08-2012 at 06:16 AM.
 
Old 09-08-2012, 12:14 AM   #9
ocicat
Member
 
Registered: May 2007
Posts: 208

Rep: Reputation: 48
Quote:
Originally Posted by Tkbp4him@insightbb.c View Post
Ok, I tried the: # mount -t_cd9660 -r /dev/cd0a /cdrom (with a added space thanks, and with the underline before the cd9660 and without it ) and I got : mount : no mount helper program found for _cd9660 : No such file or directory and before that I got same but: Invalid argument.

Also tried: # mount -a -t nonfs, mfs and got: the usage statement for mount?
It appears that keys are just being pushed.

The type of the disc can be verified through disklabel(8) which must be run as root. eg. I will be using a USB DVD drive which is identified by cd(4) with a data disc already inserted:
Code:
$ sudo disklabel cd0
# /dev/rcd0c:
type: SCSI
disk: CDROM           
label:                 
duid: 0000000000000000
flags:
bytes/sector: 2048
sectors/track: 100
tracks/cylinder: 1
sectors/cylinder: 100
cylinders: 18225
total sectors: 1822480
boundstart: 0
boundend: 1822480
drivedata: 0 

16 partitions:
#                size           offset  fstype [fsize bsize  cpg]
  a:          1822480                0 ISO9660                   
  c:          1822480                0 ISO9660                   
$
disklabel(8) must access the disc in raw character mode (even though I specified the block device), which is the reason the device is listed as /dev/rcd0c. The filesystem type ISO9660 implies that the disc can be mounted with the type "cd9660" when mounting with mount(8).

So to mount this disc, a suitable mountpoint must be found. By default, /mnt is created at installation, however some people will create subdirectories to associate different media types. For the sake of discussion here, I will assume that no subdirectories exist beneath /mnt.

By default, the permissions associated with /dev/cd0a are that of root:
Code:
$ ls -l /dev/cd0c
brw-r-----  1 root  operator    6,   2 Aug 28 14:59 /dev/cd0c
$
...so mount(8) will have to executed by root:
Code:
$ sudo mount -t cd9660 /dev/cd0a /mnt
Issuing the mount(8) command with no arguments will display all mounted partitions:
Code:
$ mount
/dev/wd0a on / type ffs (local)
/dev/wd0l on /home type ffs (local, nodev, nosuid)
/dev/wd0d on /tmp type ffs (local, nodev, nosuid)
/dev/wd0h on /usr type ffs (local, nodev)
/dev/wd0k on /usr/X11R6 type ffs (local, nodev)
/dev/wd0i on /usr/local type ffs (local, nodev)
/dev/wd0j on /usr/share type ffs (local, nodev, nosuid)
/dev/wd0e on /var type ffs (local, nodev, nosuid)
/dev/wd0f on /var/crash type ffs (local, nodev, nosuid)
/dev/wd0g on /var/git type ffs (local, nodev, nosuid)
/dev/cd0a on /mnt type cd9660 (local, read-only)
$
The last highlighted line now shows that the "a" partition on the data disc has been successfully mounted to the filesystem.
 
Old 09-08-2012, 09:43 AM   #10
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Fixed it...Awesome...

Hey, Thanks for the info, I checked out what you said and found the cd-r disc file was a UDF not ISO, and I tried via internet doing the pkg_add ftp:// etc... and was able to install Kde this way instead of cdrom drive and it worked. So, now its on my system, I just rebooted and am trying to figure out how to get to the desk top screen from the $ or # prompt? Thanks again for the help, still might need some if I can't get to desk top from here, we will see....?
 
Old 09-08-2012, 09:58 AM   #11
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
ok, how do you find it now that it upload it on my machine?

ok, how do you find the kde from $ or # after reboot?
 
Old 09-08-2012, 09:11 PM   #12
Tkbp4him@insightbb.c
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Talking Open BSD 5.1 cont. install kde

Hey, Thanks to all who help with this your awesome! I figured out how to get to Kde. Its awesome looking on the screen....Thanks millions, only been messing with it for a few months first with a free cd copy then the purchase of the orignal one of a kind and I got to work with ya'll help of coarse. Many hands make lite work....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openBSD 4.9 Install Disc: invalid opcode fault Gavin Harper *BSD 4 05-04-2011 07:36 AM
[OpenBSD 3.9] KDE copy and paste noir911 *BSD 1 09-22-2006 12:12 PM
[OpenBSD 3.9] kde konsole issues noir911 *BSD 2 06-29-2006 04:17 AM
Locating Disc 2,3,4,5 later after installing 1 Redhat disc lava Linux - General 1 03-22-2003 01:13 AM
KDE on OpenBSD 5amYan *BSD 3 06-11-2002 12:30 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 05:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration