LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices



Reply
 
Search this Thread
Old 08-05-2014, 09:56 AM   #31
kooru
Senior Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware, NetBSD
Posts: 1,371
Blog Entries: 5

Rep: Reputation: 270Reputation: 270Reputation: 270

the title of the topic misleads..
 
Old 08-05-2014, 11:42 PM   #32
Huamin
Member
 
Registered: May 2011
Posts: 355

Original Poster
Rep: Reputation: Disabled
Thanks all.
After having installed both xorg and xfce, how to start GUI interface?
 
Old 08-05-2014, 11:49 PM   #33
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,284

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Quote:
Originally Posted by Huamin View Post
Thanks all.
After having installed both xorg and xfce, how to start GUI interface?
Here is a direct quote from the FreeBSD handbook.

Quote:
Unlike GNOME or KDE, Xfce does not provide its own login manager. In order to start Xfce from the command line by typing startx, first add its entry to ~/.xinitrc:

% echo "exec /usr/local/bin/startxfce4" > ~/.xinitrc
Here is the link.

http://www.freebsd.org/doc/en_US.ISO...ok/x11-wm.html

P.S. check out the section for xorg configuation as well, for hal and dbus.

Last edited by hitest; 08-06-2014 at 12:14 AM. Reason: addition
 
1 members found this post helpful.
Old 08-13-2014, 04:12 AM   #34
Huamin
Member
 
Registered: May 2011
Posts: 355

Original Poster
Rep: Reputation: Disabled
Many thanks!
If I do not want to start the GUI upon startup now, what to adjust?
 
Old 08-13-2014, 08:13 AM   #35
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, DragonFly BSD
Posts: 1,414

Rep: Reputation: Disabled
Following hitest's advice above does not start a GUI on startup. If you followed the link and enabled a display manager such as kdm4 or gdm and now decided that you don't want it, just undo or comment out whatever you did to /etc/rc.conf
 
Old 08-13-2014, 09:55 AM   #36
angryfirelord
Member
 
Registered: Dec 2005
Posts: 502

Rep: Reputation: 60
Huamin, why did you give up on OpenBSD so quickly? All you had to do was type yes to continue without verification.....

In the event you do decide to come back to it, here's the page the deals with package management: http://www.openbsd.org/faq/faq15.html

OpenBSD comes with xenocara (a slightly modified version of X for OpenBSD), so you don't need to install it. Installing xfce is a simple matter of pkg_add -v xfce.
 
1 members found this post helpful.
Old 08-13-2014, 11:59 PM   #37
Huamin
Member
 
Registered: May 2011
Posts: 355

Original Poster
Rep: Reputation: Disabled
Many thanks all.
Cyn,
It seems that file is not editable. Any advice?
huamin@:~ % ls -l /etc/rc.conf
-rw-r--r-- 1 root wheel 164 Aug 6 09:40 /etc/rc.conf
 
Old 08-14-2014, 03:56 PM   #38
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, DragonFly BSD
Posts: 1,414

Rep: Reputation: Disabled
You would need to be root to edit configuration files in /etc
 
Old 08-14-2014, 04:10 PM   #39
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,284

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Quote:
Originally Posted by cynwulf View Post
You would need to be root to edit configuration files in /etc
Indeed. I think it is important for the OP to read the available documentation for FreeBSD.
 
Old 08-14-2014, 09:49 PM   #40
Huamin
Member
 
Registered: May 2011
Posts: 355

Original Poster
Rep: Reputation: Disabled
Hi,
Thanks Cyn.
I don't know why I can't use 'su' below.

huamin@:~ % su
su: Sorry
huamin@:~ % ls -l /etc/rc.conf
-rw-r--r-- 1 root wheel 164 Aug 6 09:40 /etc/rc.conf
 
Old 08-14-2014, 09:59 PM   #41
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]X{.0|.1|.2|-current} ::X>=12<=14, FreeBSD_10{.0|.1}
Posts: 2,203

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
With FreeBSD only users who are members of the wheel group may "su".

You will need to login as root and edit /etc/group and add user huamin to that group (like: wheel:*:0:root,huamin). Then huamin may "su".

As others have indicated, it is very much worthwhile to spend a few hours reading through the FreeBSD Handbook. I am a FreeBSD newbie myself, but what I have learned came mostly from that and the man pages and a few Ports makefiles.

Hope this helps - even with OpenBSD!

Last edited by astrogeek; 08-14-2014 at 10:05 PM.
 
Old 08-15-2014, 07:13 AM   #42
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, DragonFly BSD
Posts: 1,414

Rep: Reputation: Disabled
Typical UNIX su requires the wheel group by default. GNU su does not require it for purely ideological reasons (explained by RMS).

In case astrogeek's post was not clear, you need to actually login as the root user at a virtual terminal in order to make these changes.
 
1 members found this post helpful.
Old 08-15-2014, 01:15 PM   #43
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]X{.0|.1|.2|-current} ::X>=12<=14, FreeBSD_10{.0|.1}
Posts: 2,203

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
Quote:
Originally Posted by cynwulf View Post
Typical UNIX su requires the wheel group by default. GNU su does not require it for purely ideological reasons (explained by RMS).
I am surprised that I was unaware of this particular RMS-ism (or had forgotten it), but had recently found this difference between GNU/Linux and and FreeBSD. The man is fully committed to his cause - I admire that! Thanks for contributing to my own knowledge base!

Last edited by astrogeek; 08-15-2014 at 01:18 PM.
 
Old 08-15-2014, 09:52 PM   #44
Huamin
Member
 
Registered: May 2011
Posts: 355

Original Poster
Rep: Reputation: Disabled
Many thanks Cyn and also thanks to Astrogeek.

Cyn,
The main reason is, I had some problem to login as root when starting the machine, since I did enable GUI to this. this is also why I need to change rc.conf file.

anyway, I'm having the problem to switch to su.

Last edited by Huamin; 08-15-2014 at 10:02 PM.
 
Old 08-16-2014, 05:37 AM   #45
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, DragonFly BSD
Posts: 1,414

Rep: Reputation: Disabled
You should be able to switch to a different VT using e.g. CTRL+ALT+F2, login as root, etc.

If all else fails, boot into single user mode: http://www.freebsdwiki.net/index.php/Single-user_mode
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenBSD: nvidia drivers, screen resolution and FreeBSD binaries on OpenBSD ::: *BSD 2 08-21-2009 05:18 AM
LXer: Fsck errors in the Linux filesystem on my OpenBSD laptop NOT caused by OpenBSD LXer Syndicated Linux News 1 08-31-2008 04:15 AM
LXer: OpenBSD: The OpenBSD Foundation LXer Syndicated Linux News 0 07-26-2007 11:31 AM
OpenBSD - Where can i get OpenBSD 3.7 ISO CD -- Please help me b:z Linux - Software 5 04-08-2005 08:09 AM
OpenBSD - Where can i get OpenBSD 3.7 ISO CD -- Please help me b:z Linux - Software 1 04-07-2005 09:46 AM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration