LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices



Reply
 
Search this Thread
Old 10-25-2007, 09:45 PM   #1
farkus888
Member
 
Registered: Oct 2006
Distribution: usually use arch
Posts: 103

Rep: Reputation: 15
openBSD 4.1 and ipv6 issue


I need help stopping openBSD 4.1 from autoconfiguring ipv6 adresses on my network interfaces when they come up. the only entry in the hostname.if file for either interface is

Code:
up
whenever I reboot the computer or use ifconfig to disable and re enable one of my 2 wired network adapters they are automatically assigned ipv6 addresses which causes the bridge they are in to stop forwarding traffic.
 
Old 10-26-2007, 01:25 AM   #2
ocicat
Member
 
Registered: May 2007
Posts: 208

Rep: Reputation: 48
Quote:
Originally Posted by farkus888 View Post
I need help stopping openBSD 4.1 from autoconfiguring ipv6 adresses on my network interfaces when they come up. the only entry in the hostname.if file for either interface is

Code:
up
The usual contents of hostname.if(5) is either dhcp or inet 10.0.0.38 255.255.255.0 NONE as examples. By default, OpenBSD straddles the IPv4 & IPv6 worlds. Given that you have not specified any IPv4 directives in hostname.if, IPv6 addresses will be assigned by default. Even if IPv4 addresses are assigned, IPv6 addresses will still be available.

For more information, read hostname.if(5) & Section 6 of the FAQ:

http://openbsd.org/faq/faq6.html#Setup.if
 
Old 10-26-2007, 08:53 AM   #3
farkus888
Member
 
Registered: Oct 2006
Distribution: usually use arch
Posts: 103

Original Poster
Rep: Reputation: 15
I knew all that, I wanted a way to turn off the ipv6 addresses without assigning any v4 addresses by dhcp or static. if you read up on bridging in openBSD [section 6.9 in the link you posted] you'll see that having ip addresses on the interfaces in the bridge takes them out of promiscuous mode. which stops them from doing anything with traffic not bound for their ip address. currently I am using this quick fix...

Code:
up
!ifconfig ifname inet6 inet6address delete
in both of the hostname.if files because I noticed that every time they came up the ipv6 address was the same. this works but it seems like a bandaid solution, basically it turns on the interface which comes up with a v6 address and then manually deletes the v6 address on the command line. can anyone point me to the correct way to fix this?

Last edited by farkus888; 10-26-2007 at 03:58 PM. Reason: fixing misleading spaces
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: OpenBSD hit by 'critical' IPv6 flaw LXer Syndicated Linux News 0 03-15-2007 11:01 AM
OpenBSD 3.8 + ipv6 mebae *BSD 3 04-03-2006 05:28 AM
IPv6 issue/dhclient issue ap0ll0 Linux - Wireless Networking 10 01-27-2006 05:58 PM
automatic ipv6 module loading issue mio Slackware 1 03-27-2005 10:33 AM
Can't reach network with different distros -- IPv6 issue?? springsteenfan Linux - Networking 0 02-22-2005 05:07 PM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration