LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (http://www.linuxquestions.org/questions/%2Absd-17/)
-   -   openBSD 4.1 and ipv6 issue (http://www.linuxquestions.org/questions/%2Absd-17/openbsd-4-1-and-ipv6-issue-594663/)

farkus888 10-25-2007 08:45 PM

openBSD 4.1 and ipv6 issue
 
I need help stopping openBSD 4.1 from autoconfiguring ipv6 adresses on my network interfaces when they come up. the only entry in the hostname.if file for either interface is

Code:

up
whenever I reboot the computer or use ifconfig to disable and re enable one of my 2 wired network adapters they are automatically assigned ipv6 addresses which causes the bridge they are in to stop forwarding traffic.

ocicat 10-26-2007 12:25 AM

Quote:

Originally Posted by farkus888 (Post 2937106)
I need help stopping openBSD 4.1 from autoconfiguring ipv6 adresses on my network interfaces when they come up. the only entry in the hostname.if file for either interface is

Code:

up

The usual contents of hostname.if(5) is either dhcp or inet 10.0.0.38 255.255.255.0 NONE as examples. By default, OpenBSD straddles the IPv4 & IPv6 worlds. Given that you have not specified any IPv4 directives in hostname.if, IPv6 addresses will be assigned by default. Even if IPv4 addresses are assigned, IPv6 addresses will still be available.

For more information, read hostname.if(5) & Section 6 of the FAQ:

http://openbsd.org/faq/faq6.html#Setup.if

farkus888 10-26-2007 07:53 AM

I knew all that, I wanted a way to turn off the ipv6 addresses without assigning any v4 addresses by dhcp or static. if you read up on bridging in openBSD [section 6.9 in the link you posted] you'll see that having ip addresses on the interfaces in the bridge takes them out of promiscuous mode. which stops them from doing anything with traffic not bound for their ip address. currently I am using this quick fix...

Code:

up
!ifconfig ifname inet6 inet6address delete

in both of the hostname.if files because I noticed that every time they came up the ipv6 address was the same. this works but it seems like a bandaid solution, basically it turns on the interface which comes up with a v6 address and then manually deletes the v6 address on the command line. can anyone point me to the correct way to fix this?


All times are GMT -5. The time now is 01:53 PM.