LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 11-11-2005, 03:17 PM   #1
klemen
Member
 
Registered: Dec 2004
Location: Slovenia
Distribution: Slackware and OpenBSD
Posts: 87

Rep: Reputation: 15
openbsd 3.8 and virtualhosts error


hello

I have a problem with virtual hosts. I direct every hostname in specific directory, but they all showing the same, main site. Error log show me that:

11 22:19:22 2005] [warn] VirtualHost www.xyxyxy.si:80 overlaps with VirtualHost www.fdfdgdfdf.si:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Nov 11 22:19:22 2005] [warn] VirtualHost www.t4656565.si:80 overlaps with VirtualHost www.34343434.si:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Nov 11 22:19:22 2005] [warn] VirtualHost www.23243534:80 overlaps with VirtualHost www.565656565.si:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Fri Nov 11 22:19:22 2005] [warn] NameVirtualHost 192.168.2.104:8080 has no VirtualHosts


But I have an VirtualHost directive, whitch is the internal ip of my server (on that server I have dns too).

I also make the /named/ configurations and use the ip 192.168.2.104.

What's wrong?
 
Old 11-12-2005, 01:25 AM   #2
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
The log is telling you the problem -- "you need a NameVirtualHost directive"

It's in httpd.conf by default, but commented out.
 
Old 11-21-2005, 08:56 PM   #3
raven.sorrow
Member
 
Registered: Oct 2004
Distribution: Gentoo/FBSD/Slack
Posts: 65

Rep: Reputation: 15
I am having a similar problem. Let me lay out the basics..

I am running a Gentoo system:
Code:
LittleGeek vhosts.d # cat /etc/gentoo-release
Gentoo Base System version 1.6.12
LittleGeek vhosts.d #

and I am running the following apache version.
Code:
LittleGeek vhosts.d # apache -v
Server version: Apache/2.0.54
Server built:   Nov 17 2005 18:47:23
LittleGeek vhosts.d #

I set the default vhost as the servers NAT IP of 192.168.0.20

and in the /etc/apache2/vhost.d/ I have created the following vhost's
Code:
LittleGeek vhosts.d # ls
00_default_vhost.conf        paste.starforcesim.net.conf  www.sample.com.conf
chaos.starforcesim.net.conf  serina.xaerolimit.net.conf   www.xaerolimit.net.conf
LittleGeek vhosts.d #
  • 00_default_vhost.conf has the NAT IP and points to /var/www/localhost
  • www.xaerolimit.net.conf does work when I and others surf to it they see a quote that I put there.
  • chaos.starforcesim.net was working and then it stoped. Right now when you go to it all you will see is the default apache test page, but when you go to it you *should* see 1 line of text w/ the uri in it, just to let me know it did work correctly.
  • paste.starforcesim.net is working the same as chaos.*
  • serina.xaerolimit.net is also working the same as *.starforcesim.net
  • all of the vhosts are the same in syntax, only difference is changing each part for the respective vhost.

All hosts do point/resolve to my World IP.

The problems that I am encountering are as follows.
  1. Not all of my VHOSTS are working.
  2. /somedir/ under www.xaerolimit.net does exist but I am unable to surf to it. Everything under that dir is chmod 755 just to make sure it was working right.


Hopefully I have posted enough information. If I have no feel free to say so and I will post the relevance request.
 
Old 11-23-2005, 04:23 PM   #4
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
Are you using named virtual hosts or IP virtual hosts? Meaning, please post the config(s) for one of your vitual hosts.

Also, do you have "NameVirtualHost *:80" uncommented in httpd.conf?
 
Old 11-24-2005, 12:18 PM   #5
raven.sorrow
Member
 
Registered: Oct 2004
Distribution: Gentoo/FBSD/Slack
Posts: 65

Rep: Reputation: 15
I solved this by adding the following to each of my confs in /etc/apache2/vhost.d/

Code:
    <Directory "/home/xaero/public_html">
        Options All Indexes
        Order allow,deny
        Allow from all
    </Directory>
each sniplet above was adjusted for each vhost and it was also added to my sample conf to ensure I do it each time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error on pkg_add on openbsd 3.8 klemen *BSD 0 10-06-2005 12:56 PM
Apache Virtualhosts + PHP error critical Linux - Software 3 08-03-2005 01:21 AM
openBSD 3.5 sm-msp-queue error ? smurfzilla *BSD 5 08-31-2004 12:05 PM
Stange OpenBSD 3.5 error. lil_drummaboy *BSD 2 05-23-2004 07:05 PM
dns error messages in openbsd 3.1 glock19 Linux - Networking 2 06-25-2002 05:50 AM


All times are GMT -5. The time now is 03:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration