LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 02-08-2007, 05:44 PM   #1
murrayfoss
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Rep: Reputation: 0
no DHCPOFFERS received. (SOLVED 2/9/07)


I have a Toshiba Satellite M45-S331 Laptop computer.
It has a PRO/wireless 2200BG ethernet card(internal).
I have a Linksys WRT54GS v2.0 router with firmware v4.71.1(upgraded from version that came with router; downloaded from Linksys.com's official download area for my specific router).

Windows Vista and Ubuntu detected and ran dhcp and established an IP.
FreeBSD is not assigning an IP.

I've installed the ports iwi-firmware, iwi-firmware-kmod and added the package iwi-firmware-2.4_7.tbz.

I then added the following lines into /boot/loader.conf
if_iwi_load="YES"
wlan_load="YES"
firmware_load="YES"

I then rebooted and typed ifconfig into shell, iwi0 was found and appeared to be working.
Then I typed the following into shell
ifconfig iwi0 inet 192.168.2.1 netmask 255.255.255.0 ssid Starfleet bssid 00:13:10:66:58:f8 channel 6 wepkey 12345 weptxkey 1 wepmode mixed

Then the following
ifconfig iwi0 up

Then
dhclient iwi0

Here in lies the problem, it runs for maybe a minute and continually prints out DHCPDISCOVER on iwi0 to 255.255.255.255 port 67 interval 4
with multiple different intervals.
Then it prints out
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I know that I run WEP and not WPA or any of the others.
Also, incase you are wondering the ifconfig iwi0 command brings up my carrier as being associated.

From here I am out of ideas, other than something I read about PPPoE, but after trying to set that up via my router located at 192.168.2.1 I noticed that I couldn't get a connection in Vista so I didn't try it in FreeBSD or Ubuntu.

Now is there a way of setting up FreeBSD as a static IP address, because I've done it in Vista by changing a few network things, would this help?
I'd like to be able to run DHCP versus any alternatives. I'm going to continue reading the handbook for things I mentioned in this post, but if I'm on the right track or you could point me in the right direction I'd very much appreciate it.

I've all ready been to (it says I can't submit url's to LQ yet so I'll just say it's damien.bergamini.free.fr under the sub directory of /ipw/iwi-freebsd.html) and followed the guide there, even tho, it is out of date and discontinued, it helped some, but not completely; considering the false data concerning version of firmware 2.3_1 not being available anymore (2.4_7 is at this time, of this post, the only firmware version available via ports. Also, out of date is the location of /usr/local/libdata/if_iwi it is now /boot/firmware) not to mention, the very talented Damien Bergamini abandoning his work on FreeBSD in order to pursue ventures in OpenBSD.

Please help.

Thank you,
Michael Ciccarelli, Jr.
Ciccarelli's Lawn Maintenance, Inc.

Last edited by murrayfoss; 02-09-2007 at 05:40 PM.
 
Old 02-08-2007, 06:26 PM   #2
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Quote:
Originally Posted by murrayfoss
I then rebooted and typed ifconfig into shell, iwi0 was found and appeared to be working.
Then I typed the following into shell
ifconfig iwi0 inet 192.168.2.1 netmask 255.255.255.0 ssid Starfleet bssid 00:13:10:66:58:f8 channel 6 wepkey 12345 weptxkey 1 wepmode mixed
It seems to me that you're assigning it a static address right here, but it's probably the IP that your gateway should have.

I believe if you replace "192.168.2.1" with the IP address that you would like your wireless interface to have (static) that you do not need to issue the dhclient command and you should be ready to go. Oh, you also need to
Code:
# route add -net default 192.168.2.1 255.255.255.0
(assuming 192.168.2.1 is the IP address of your gateway)
 
Old 02-08-2007, 07:38 PM   #3
murrayfoss
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chort
I believe if you replace "192.168.2.1" with the IP address that you would like your wireless interface to have (static) that you do not need to issue the dhclient command and you should be ready to go. Oh, you also need to
# route add -net default 192.168.2.1 255.255.255.0
Thank you Chort for taking interest in my thread, I did what you suggested and changed inet 192.168.2.1 to inet 192.168.2.150 and it associated as it did before. Then I gave the route add -net default 192.168.2.1 255.255.255.0 command.

Then I did ping google.com and got no reply (actually a no remote something reply, I don't remember exactly).

I'm new to FreeBSD and that's the only way I know how to check if the Internet is working. Then I did dhclient iwi0 and got the same message as before, no DHCPOFFERS received.

Also I should note that I'm trying to connect to my router via wireless laptop and it is not physically connected to the router, the router is on the PC. You probably all ready knew that but I wanted to be clear, after reading my earlier post I realized I may have left that part out.

Thank you again,
Michael Ciccarelli, Jr.
Ciccarelli's Lawn Maintenance, Inc.
 
Old 02-08-2007, 09:42 PM   #4
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
If you boot the laptop to Windows (or another OS) and get an IP address on the wireless interface with DHCP, what IP address does it get and what is the gateway address?
 
Old 02-08-2007, 10:37 PM   #5
murrayfoss
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chort
what IP address does it get and what is the gateway address?
Microsoft Windows [Version 6.0.6000]

IPv4 Address. . . . . . . . . . . . . . . . : 192.168.2.103(Preferred)
Subnet Mask. . . . . . . . . . . . . . . . : 255.255.255.0
Default Gateway. . . . . . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . . . . . . : 192.168.2.1
DNS Servers . . . . . . . . . . . . . . . . : 205.152.144.23
. . . . . . . . . . . . . . . . . . . . . . . . . : 205.152.132.23

That was some of the information from doing an ipconfig /all in a command prompt shell. Also, the portion marked "(Preferred)" was added by Windows, not me. Now, I know those are the local IP's for me to connect to the router but doing a /dns on my nickname in mIRC gives the following, I don't know if it's relevant, but it gave me "Dns resolved 72.153.173.94 to adsl-153-173-94.mia.bellsouth.net"

Thank you very much for your continued help in this matter,
Michael Ciccarelli, Jr.
Ciccarelli's Lawn Maintenance, Inc.

Last edited by murrayfoss; 02-09-2007 at 05:48 PM.
 
Old 02-09-2007, 12:57 AM   #6
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
So basically that's how you should ifconfig your interface in FreeBSD.

Try:
Code:
# ifconfig iwi0 inet 192.168.2.103 netmask 255.255.255.0 ssid Starfleet bssid 00:13:10:66:58:f8 channel 6 wepkey 12345 weptxkey 1 wepmode mixed
# route add -net default 192.168.2.1
Edit /etc/resolv.conf and add the following two lines (should be the only two lines in the file):
Code:
nameserver 205.152.144.23
nameserver 205.152.132.23
After that, do
Code:
# ifconfig iwi0
and paste the output here so we can see what's going on.

PS I incorrectly told you to add a netmask to the default route in my previous post. That's wrong, just use what I posted in this post.
 
Old 02-09-2007, 05:35 PM   #7
murrayfoss
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chort
# ifconfig iwi0 inet 192.168.2.103 netmask 255.255.255.0 ssid Starfleet bssid 00:13:10:66:58:f8 channel 6 wepkey 12345 weptxkey 1 wepmode mixed
# route add -net default 192.168.2.1
Good news Chort, we got it working. \o/

It turns out that the wepkey I was using, was the problem, even though I know it's the correct passphrase, I turned off the wireless encryption and then "YESSS!", worked like a charm. I could have left it like this and went on being happy about having a connection, but hey I like my neighbors and all, but, lets face it, I need all the bandwidth I can get. So, barring leaving it unencrypted, I set out on a new mission to get the encryption working.

I read in the ifconfig man page under the wepkey switch that FreeBSD is set for 40 bits or 104 bits encryption, and my router uses 64 bits or 128 bits encryption. I currently have it set to 64 bits (5 digit plain text passphrase). Now, this confused me because I read on some web page about router specific encryption (can't remember which web page) that these two different amounts are actually the same exact things (i.e. 40 bits = 64 bits and 104 bits = 128 bits), but it also suggested using the hex form of the password when authenticating it, just to play it safe. Now, in FreeBSD it requires a 0x proceeding the 10 digit hex version of the passphrase (case sensitive - all uppercase except for the 0x part, x being lowercase) This is where it gets kinda confusing because in Vista it's also case sensitive but all lowercase, strange huh? Now, in Ubuntu I enter it in lowercase, then around-and-around we go...

Currently I am going to continue my journey of reading through the handbook for I now know these blunders can be avoided with a little more knowledge on my part so I don't wind up on these boards complicating your days.

I appreciate all that you did for me and I want you to know, for further reference, I didn't need to pass the route add command to get connected. Also, I used 192.168.2.1 as my inet instead of the afore mentioned 103, but 103 works as well, apparently one can give it nearly any numbers as long as the first two sets are 192 and 168, if one were so inclined.

It is a good day indeed my friend, I suggest a round of beers for celebration. Until then, good luck to you and yours, and God bless.

Thank you very much,
Michael Ciccarelli, Jr.
Ciccarelli's Lawn Maintenance, Inc.

Last edited by murrayfoss; 02-09-2007 at 06:02 PM.
 
Old 02-09-2007, 06:30 PM   #8
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
You might find wepkey converter useful. Just prefix the hex result with 0x. 40bit is the same thing as 64bit, it's just that the industry likes to call 40bit keys "64bit" because it sounds like "stronger" encryption, when in fact only 40 of those bits are the actual key (how's that for marketing?).
 
Old 02-09-2007, 07:52 PM   #9
murrayfoss
LQ Newbie
 
Registered: Aug 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chort
(how's that for marketing?).
Well I don't like that a bit, for too many years these big companies (technology included) promise more out of the box than what is received, since a company like Linksys is so well established, we trust them. I guess in the end it pays to get educated and not believe everything you hear. The Better Business Bureau should be informed of this discrepancy (I thought that was what they're there for).

A small company like mine couldn't cut three quaters of a lawn, then leave, so why is it okay for Linksys to sell three quaters worth of security and advertise more?

It's outrageous (even though I use the 40 bit encryption because it's easier for me to remember). I might not have went with it if I had known that.

Here's a scenario for you, a neighbor breaks your supposed 64 bit encryption and then proceeds to carry on illegal activities under your name, and your name gets dragged through the muck, you then possibly even get charged with a crime. Now, wouldn't I have the right to sue Linksys for the deception.

Even if I did, I'd run out of money before I ever saw a verdict, whereas Linksys wouldn't even consider settling out of court unless I wanted a small amount of money or the Lawyer (firm) arguing my case specifically targeted big business in hopes to get a monopoly around the world (much like sensationalist reporters exploiting people for personal gain), to get in on a precedent (to ride the wave of misery and shake hands with the devil). Like a while back when all these water companies got sued. One win and the next thing you know lawyers all around the country are suing Router companies because of the legal precedent and now the price of the product doubles (and in the end the working man pays).

It's a daisy chain of irrefutable negatives, and for what, Linksys making a couple bucks by cutting corners and sneaky sales campaigns.

The whole idea disgusts me.

Michael Ciccarelli, Jr.
Ciccarelli's Lawn Maintenance, Inc.

Last edited by murrayfoss; 02-09-2007 at 07:54 PM.
 
Old 02-09-2007, 08:32 PM   #10
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
It's the same as hard disk drive makers artificially inflating the size of their drives by counting 1000 KB = 1 MB (instead of 1024 KB = 1 MB). You get an 80GB drive and realize there are actually only 70something GB according to your OS (which counts in binary). Marketing cheats us all the time
 
  


Reply

Tags
dhclient, dhcpoffers, ifconfig, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No DHCPOFFERS received m0llbuz_ Linux - Networking 6 07-29-2010 02:08 PM
No DHCPOFFERS received antonucc Linux - Networking 8 12-07-2006 04:06 AM
NO DHCPOFFERS received ekdya Debian 7 04-27-2006 04:09 AM
FC4 ipw2100 - No DHCPOFFERS received tingcm Linux - Wireless Networking 4 08-22-2005 03:43 AM


All times are GMT -5. The time now is 09:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration