LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 09-22-2006, 05:26 PM   #1
taylor_venable
Member
 
Registered: Jun 2005
Location: Indiana, USA
Distribution: OpenBSD, Ubuntu
Posts: 892

Rep: Reputation: 41
NetBSD 3.0.1 XFree86 xauth seg fault


Hi, guys;

I did an install of NetBSD 3.0.1 yesterday and it almost works perfectly. The problem I have is that when XFree86 shuts down, xauth seg faults. From what I understand, it tries to clean up the .Xauthority files it created when the X server (which is version 4.5.0 by the way) starts, but then seg faults and dumps core instead.

Exactly what happens is that the message "waiting for X server to shut down" is printed, then I get the message "Segmentation fault (core dumped) xauth remove ${r..." I assume the command that's seg faulting is "xauth remove $removelist" from /usr/X11R6/bin/startx.

I've searched on the matter, but haven't yet found it elsewhere. Any ideas are, as always, greatly appreciated.

EDIT:

Well, I've come up with a workaround - using the last line of my .xinitrc file to remove the .Xauthority file prevents xauth from seg faulting. So it works, but I still wish I knew why it was happening. I don't have the chops or the time right now to delve deep into debugging, though.

Last edited by taylor_venable; 09-23-2006 at 02:17 PM.
 
  


Reply

Tags
xauth, xfree86


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
weird seg fault zaichik Programming 7 01-29-2005 07:34 AM
RH 7.2 crash...getting seg fault when using ls sakima Red Hat 1 10-11-2004 10:14 AM
C seg fault drigz Programming 5 10-01-2004 04:35 PM
Installed XFree86. It can't find xauth or xinet. gnomes Linux - Software 3 08-05-2004 04:07 PM
ut2004 seg fault dopefish Linux - Games 3 04-11-2004 03:44 AM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration