LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 07-22-2008, 06:29 AM   #1
paragkalra
Member
 
Registered: Sep 2006
Location: Nagpur, Maharashtra, India
Distribution: Debian, Ubuntu, Redhat, Fedora, SLES, OpenSUSE, FreeBSD, Mac OS X
Posts: 221

Rep: Reputation: 31
Keeping DATE setting constant in FreeBSD 7.0


Hello all,

I am using FreeBSD 7.0 on VMware. I am facing a serious issue. The date on my FreeBSD server is changing continuously i.e. the clock is running slow and is not able to match the clock of my host (Windows machine). I guess it has something to do with NTP server setting or may be UTC clock setting but I am not sure.

My only requirement is that I want to keep my clock constant according to my timezone (IST/India)
 
Old 07-22-2008, 10:03 AM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
NB: there are a number of gotchas when running a vmware FBSD guest under a Windows host. Do not query someone's ntp server constantly to solve this problem.

In your case, you'll need to add the following entries to /boot/loader.conf:
Code:
kern.hz=100
hint.apic.0.disabled=1
Also be sure your timezone is set properly (with tzsetup).
 
Old 07-23-2008, 05:11 AM   #3
paragkalra
Member
 
Registered: Sep 2006
Location: Nagpur, Maharashtra, India
Distribution: Debian, Ubuntu, Redhat, Fedora, SLES, OpenSUSE, FreeBSD, Mac OS X
Posts: 221

Original Poster
Rep: Reputation: 31
@anomie

I placed the entry suggested by you and now the system is not booting up. I am getting following prompt:
Quote:
mountroot>
Please help....

Last edited by paragkalra; 07-23-2008 at 05:29 AM.
 
Old 07-23-2008, 12:42 PM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Strange. Are you sure you specified the entries correctly and put them into the correct file?

To remove them, boot to single user mode.

http://www.freebsd.org/doc/en_US.ISO...ooks/handbook/
 
Old 07-30-2008, 10:25 AM   #5
paragkalra
Member
 
Registered: Sep 2006
Location: Nagpur, Maharashtra, India
Distribution: Debian, Ubuntu, Redhat, Fedora, SLES, OpenSUSE, FreeBSD, Mac OS X
Posts: 221

Original Poster
Rep: Reputation: 31
Finally I got rid of this issue by placing the line "kern.hz=100" in "/boot/loader.conf" file as suggested by anomie:

In my case it worked without placing the line "hint.apic.0.disabled=1". In fact because of it my system was not booting. Anyways thanks anomie

Also just to add more info, in the process of resolving this issue I came across following good docs:

http://www.freebsd.org/doc/en/books/...ion-guest.html
http://www.vmware.com/pdf/vmware_timekeeping.pdf
 
Old 07-30-2008, 11:02 AM   #6
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Good work. Thanks for posting back.
 
  


Reply

Tags
clock, date, utc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keeping Slackware Up-to-date Bash Rules Slackware 22 09-08-2009 10:20 PM
Keeping Slackware 12.1 up to date. glore2002 Slackware 10 06-18-2008 09:58 AM
Keeping Slackware Up-To-Date introuble Slackware 4 03-21-2006 08:08 AM
Compiling "nvidia-settings" an keeping FreeBSD up-to-date dabang *BSD 4 12-31-2005 04:20 PM
Keeping OpenBSD up to date Gsee *BSD 6 12-03-2004 11:58 AM


All times are GMT -5. The time now is 12:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration