LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
Search this Thread
Old 10-31-2005, 03:52 PM   #1
KlaymenDK
Member
 
Registered: Sep 2003
Location: Denmark
Distribution: FreeBSD v6.0
Posts: 123

Rep: Reputation: 15
KDE login dialog (3 questions)


I didn't quite know where to put this, but since I'm using FreeBSD v5.4 I'll risk it here. My KDE version is 3.4.0, the default for the release.

The thing is, I'm looking for some convenience tweaks for the login dialog (once I am logged in, I have configured my session just fine).

-- Num Lock is off, this is a bit annoying since I often use numbers in my password.
-- I use a Dvorak keyboard layout, but the login dialog uses qwerty. This is an unreasonably big problem mainly because it messes up my password-entering muscle memory.
-- I tried to use the autologin feature, but when the system boots I get an "Authenticating klaymen ... Authentication failed" error, and after that I can log in normally using the login dialog.

How can I change these things? Are they better in FreeBSD v5-release, or v6?
 
Old 10-31-2005, 06:01 PM   #2
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
Re: KDE login dialog (3 questions)

Quote:
Originally posted by KlaymenDK
I didn't quite know where to put this, but since I'm using FreeBSD v5.4 I'll risk it here. My KDE version is 3.4.0, the default for the release.

The thing is, I'm looking for some convenience tweaks for the login dialog (once I am logged in, I have configured my session just fine).

-- Num Lock is off, this is a bit annoying since I often use numbers in my password.
-- I use a Dvorak keyboard layout, but the login dialog uses qwerty. This is an unreasonably big problem mainly because it messes up my password-entering muscle memory.
-- I tried to use the autologin feature, but when the system boots I get an "Authenticating klaymen ... Authentication failed" error, and after that I can log in normally using the login dialog.

How can I change these things? Are they better in FreeBSD v5-release, or v6?
1.) Search your ports for numlockx. Build and install it. Then edit your .xinitrc file and add the following line before starting KDE
Code:
exec numlockx &
That will turn on the numlock key before KDE starts.

Since I don't actually use KDE, I am no help for 2 and 3.

Cheers--
Charles
 
Old 11-01-2005, 04:33 PM   #3
AllenX
LQ Newbie
 
Registered: Sep 2005
Location: Ottawa, Ontario, Canada
Distribution: FreeBSD,SuSE
Posts: 15

Rep: Reputation: 0
1) To fix the Num Lock:
K Menu
--> Control Center / Peripherals / keyboard / NumLock on KDE Startup / Turn on

2) I don't have any experience with dvorak layouts, but their is some functionality relating to layouts in
--> Control Center / Regional & Accessibility / keyboard layout /....
or you might try xorgconfig from a terminal (run as root) to see if you can select the correct default layout

3) sorry, can't help you with the autologin.

PS. These are KDE settings, not related to any specific version of FreeBSD.
 
Old 11-02-2005, 02:38 AM   #4
KlaymenDK
Member
 
Registered: Sep 2003
Location: Denmark
Distribution: FreeBSD v6.0
Posts: 123

Original Poster
Rep: Reputation: 15
@AllenX:
Yes, you are quite correct regarding these options; but they are user-specific and take effect the moment I login -- not before.

I've had the same problem on WXP at work; it IS possible but NOT simple (nor documented).
 
Old 11-02-2005, 06:00 PM   #5
AllenX
LQ Newbie
 
Registered: Sep 2005
Location: Ottawa, Ontario, Canada
Distribution: FreeBSD,SuSE
Posts: 15

Rep: Reputation: 0
I noticed in sysinstall there are number of dvorak layouts for the console, or look in /usr/share/syscons/keymaps for the same list and update /etc/rc.conf manually, maybe that would do the trick?

This seems related to your autologin issue...
http://frontrangebsd.org/pipermail/k...il/007997.html

Good luck!
 
Old 11-06-2005, 12:58 PM   #6
KlaymenDK
Member
 
Registered: Sep 2003
Location: Denmark
Distribution: FreeBSD v6.0
Posts: 123

Original Poster
Rep: Reputation: 15
That's a very good idea! I got the default system console to use Norwegian Dvorak. I did this by using sysinstall: "Configure -> Console -> Font" and select #8, "ISO 8859-1 Western Europe". I left the "Screenmap" set to "None".

However, this has the side-effect of causing the "box drawing" characters to go all funky, but I can live with that. It does not, however, change anything in X, so my login dialog is still the same.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crazy blank dialog boxes and windows at login. Can't login as user soren625 Linux - General 2 08-11-2004 06:30 AM
KDE system halt dialog corbis_demon Linux - Software 1 08-06-2004 12:00 AM
permissions dialog in kde geomatt Linux - Newbie 4 07-30-2004 10:04 AM
Dragon on logout dialog in KDE... craigs1987 Linux - Software 2 07-06-2004 04:25 PM
Apache: login dialog presented without .htaccess dkochan Linux - Networking 2 02-29-2004 07:39 PM


All times are GMT -5. The time now is 01:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration